summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm143
1 files changed, 111 insertions, 32 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index b60857b264..212c2b3715 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -36,7 +36,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2021, 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021, 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 Hyunseok Kim <lasnesne@lagunposprasihopre.org>
@@ -47,7 +47,7 @@
;;; Copyright © 2021 muradm <mail@muradm.net>
;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
-;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2021-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
@@ -65,6 +65,7 @@
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -114,6 +115,7 @@
#:use-module (gnu packages c)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages crates-graphics)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages crates-windows)
@@ -122,6 +124,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages datastructures)
+ #:use-module (gnu packages debian)
#:use-module (gnu packages dns)
#:use-module (gnu packages elf)
#:use-module (gnu packages file)
@@ -232,23 +235,30 @@ simplicity in mind.")
(define-public aide
(package
(name "aide")
- (version "0.16.2")
+ (version "0.18.8")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/aide/aide/releases/download/v"
version "/aide-" version ".tar.gz"))
(sha256
- (base32 "15xp47sz7kk1ciffw3f5xw2jg2mb2lqrbr3q6p4bkbz5dap9iy8p"))))
+ (base32 "0q1sp0vwrwbmw6ymw1kwd4i8walijwppa0dq61b2qzni6b32srhn"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags #~(list "--with-posix-acl"
+ "--with-selinux"
+ "--with-xattr"
+ "--with-config-file=/etc/aide.conf")))
(native-inputs
- (list bison flex))
+ (list bison flex pkg-config))
(inputs
- (list libgcrypt
+ (list acl
+ attr
+ libgcrypt
libgpg-error
libmhash
- `(,pcre "static")
- pcre
+ libselinux
+ pcre2
`(,zlib "static")
zlib))
(synopsis "File and directory integrity checker")
@@ -397,7 +407,8 @@ interface and is based on GNU Guile.")
;; affects any system without a functional real-time
;; clock (RTC), but in practice these are typically Arm
;; single-board computers.
- (if (target-arm?)
+ (if (or (target-arm?)
+ (target-riscv64?))
guile-fibers-1.1
guile-fibers))))
(inputs (modify-inputs (package-inputs shepherd-0.9)
@@ -755,7 +766,7 @@ console.")
(define-public btop
(package
(name "btop")
- (version "1.3.0")
+ (version "1.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -764,7 +775,7 @@ console.")
(file-name (git-file-name name version))
(sha256
(base32
- "0fbrkzg03n2vamg1pfzdb8wxm3xffy6gp4izhqppl45zngy3c0s1"))))
+ "084n0nbv1029lvfv4na2k9fqyray7m77dff1537b8ffk08ib4d4j"))))
(build-system gnu-build-system)
(arguments
(list #:tests? #f ;no test suite
@@ -825,7 +836,7 @@ on memory usage on GNU/Linux systems.")
(define-public htop
(package
(name "htop")
- (version "3.2.2")
+ (version "3.3.0")
(source
(origin
(method git-fetch)
@@ -833,7 +844,7 @@ on memory usage on GNU/Linux systems.")
(url "https://github.com/htop-dev/htop")
(commit version)))
(sha256
- (base32 "0cyaprgnhfrc7rqq053903bjylaplvxkb65b04bsxmiva09lvf9s"))
+ (base32 "0g2rpp9plblmd9khic2f06089hfh0iy521dqqnr3vkin6s9m0f58"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(inputs
@@ -1563,7 +1574,8 @@ connection alive.")
(coreutils (assoc-ref inputs "coreutils*"))
(inetutils (assoc-ref inputs "inetutils"))
(grep (assoc-ref inputs "grep*"))
- (sed (assoc-ref inputs "sed*")))
+ (sed (assoc-ref inputs "sed*"))
+ (debianutils (assoc-ref inputs "debianutils")))
(substitute* "client/scripts/linux"
(("/sbin/ip")
(search-input-file inputs "/sbin/ip")))
@@ -1578,7 +1590,7 @@ connection alive.")
,(map (lambda (dir)
(string-append dir "/bin:"
dir "/sbin"))
- (list inetutils coreutils grep sed))))))))))
+ (list inetutils coreutils grep sed debianutils))))))))))
(native-inputs
(list config perl file))
@@ -1589,6 +1601,10 @@ connection alive.")
'()
`(("iproute" ,iproute)))
+ ;; dhclient-script provides hooks to users and uses run-parts in
+ ;; order to list users defined hooks.
+ ("debianutils" ,debianutils)
+
;; isc-dhcp bundles a copy of BIND, which has proved vulnerable
;; in the past. Use a BIND-VERSION of our choosing instead.
("bind-source-tarball"
@@ -3227,31 +3243,31 @@ frequently used directories by typing only a small pattern.")
(define-public fasd
(package
(name "fasd")
- (version "1.0.1")
+ (version "1.0.2")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/clvv/fasd")
+ (url "https://github.com/whjvenyl/fasd")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "1awi71jdv3mhjrmar2d4z1i90kn7apd7aq1w31sh6w4yibz9kiyj"))))
+ "0q72a54dcahc9pan5qkmnsvpqiqgjjxwdxzzm8pxzylpr329jjyh"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(delete 'configure)) ;no configuration
#:tests? #f ;no tests
#:make-flags (list (string-append "PREFIX=" %output))))
- (home-page "https://github.com/clvv/fasd")
+ (home-page "https://github.com/whjvenyl/fasd")
(synopsis "Quick access to files and directories for shells")
(description
- "Fasd (pronounced similar to \"fast\") is a command-line productivity
-booster. Fasd offers quick access to files and directories for POSIX shells.
-It is inspired by tools like autojump, z, and v. Fasd keeps track of files
-and directories you have accessed so that you can quickly reference them in
-the command line.")
- (license license:x11)))
+ "Fasd (pronounced similar to \"fast\") is a command-line productivity booster.
+Fasd offers quick access to files and directories for POSIX shells. It is inspired
+by tools like @code{autojump}, @code{z}, and @code{v}. Fasd keeps track of files and
+directories you have accessed so that you can quickly reference them in the command
+line.")
+ (license license:expat)))
(define-public iftop
(package
@@ -4704,7 +4720,7 @@ cache of unix and unix-like systems.")
(define-public solaar
(package
(name "solaar")
- (version "1.0.7")
+ (version "1.1.13")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4713,7 +4729,7 @@ cache of unix and unix-like systems.")
(file-name (git-file-name name version))
(sha256
(base32
- "0k7mjdfvf28fay50b2hs2z4qk6s23h71wvl8777idlrz5i5f43j5"))))
+ "1fz3qgjx3ygr4clgh7iryxgvvjy510rgy8ixr2xld2wr0xa6p0mi"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -4721,9 +4737,12 @@ cache of unix and unix-like systems.")
(add-before 'build 'setenv-PATH
(lambda _
(setenv "PYTHONPATH" "lib"))))))
+ (native-inputs (list python-pytest))
(propagated-inputs
(list python-pygobject
python-pyudev
+ python-dbus-python
+ python-evdev
;; For GUI.
python-pyyaml
python-psutil
@@ -4946,7 +4965,7 @@ elogind's uaccess feature.")
(define-public jc
(package
(name "jc")
- (version "1.23.4")
+ (version "1.25.2")
(source
(origin
;; The PyPI tarball lacks the test suite.
@@ -4956,7 +4975,7 @@ elogind's uaccess feature.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "07ic7pd9684k59f6zycn20903q31jdacqqjymrbr5zqj4qv8whkp"))))
+ (base32 "17cik2jlj3ph7bsyn73gdp8d32nc56dmb96ijmzpwm0kdvd7sdj8"))))
(build-system pyproject-build-system)
(arguments
(list #:phases
@@ -5115,14 +5134,14 @@ Netgear devices.")
(define-public atop
(package
(name "atop")
- (version "2.9.0")
+ (version "2.10.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.atoptool.nl/download/atop-"
version ".tar.gz"))
(sha256
(base32
- "09prpw20ps6cd8qr63glbcip3jrvnnic0m7j1q02g8hjnw8z50ld"))
+ "14szbpvsm9czib1629cbh8qcp7pxhgn0vjrfv1yqwmw25k7p79p7"))
(snippet
;; The 'mkdate' script generates a new 'versdate.h' header
;; containing the build date. That makes builds
@@ -5150,8 +5169,10 @@ Netgear devices.")
;; Otherwise, it creates a blank configuration file as a "default".
(("touch.*DEFPATH)/atop") "")
(("chmod.*DEFPATH)/atop") "")))))))
+ (native-inputs (list pkg-config))
(inputs
- (list ncurses
+ (list glib
+ ncurses
python-wrapper ; for `atopgpud`
zlib))
(home-page "https://www.atoptool.nl/")
@@ -5716,6 +5737,64 @@ mediate access to shared devices, such as graphics and input, for applications
that require it.")
(license license:expat)))
+(define-public sysdig
+ ;; Use the latest commit for now, as the latest 0.36.1 release does not yet
+ ;; support the falcosecurity-libs 0.16 API.
+ (let ((commit "598ad292b659425e475e5814d9e92c3c29188480")
+ (revision "0"))
+ (package
+ (name "sysdig")
+ (version (git-version "0.36.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/draios/sysdig")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yyins3rb286dfibadfwwp2gwmdj7fsz3pdkpdvx05yvdqfkqds7"))
+ (patches
+ (search-patches "sysdig-shared-falcosecurity-libs.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:configure-flags
+ #~(list "-DUSE_BUNDLED_DEPS=OFF"
+ ;; Already built and part of falcosecurity-libs, but
+ ;; needed for the 'HAS_MODERN_BPF' define.
+ "-DBUILD_SYSDIG_MODERN_BPF=ON"
+ #$(string-append "-DSYSDIG_VERSION=" version))))
+ (native-inputs (list pkg-config))
+ (inputs
+ (list falcosecurity-libs
+ luajit
+ ncurses
+ nlohmann-json
+ yaml-cpp
+ zlib))
+ (home-page "https://github.com/draios/sysdig")
+ (synopsis "System exploration and troubleshooting tool")
+ (description "Sysdig is a simple tool for deep system visibility, with
+native support for containers. It combines features of multiple system
+administration tools such as the @command{strace}, @command{tcpdump},
+@command{htop}, @command{iftop} and @command{lsof} into a single interface.
+The novel architecture of the tool means that the performance impact of the
+tracing on the system is very light, compared to the likes of
+@command{strace}. The @command{sysdig} command has an interface similar to
+@command{strace}, while the @command{csysdig} command is better suited for
+interactive used, and has a user interface similar to @command{htop}.
+
+If you use Guix System, the kernel Linux has @acronym{BPF, Berkeley Packet
+Filter} support, and you should launch this tool using the @samp{--modern-bpf}
+argument of the @command{sysdig} or @command{csysdig} commands. The following
+Bash aliases can be added to your @file{~/.bash_profile} file, for example:
+
+alias sysdig=sudo sysdig --modern-bpf
+alias cysdig=sudo csysdig --modern-bpf
+") ;XXX no @example Texinfo support
+ (license license:asl2.0))))
+
(define-public fail2ban
(package
(name "fail2ban")