summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c2599746d8..83b01808cd 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -29,6 +29,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages base)
+ #:use-module (gnu packages file)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages readline)
#:use-module (gnu packages linux)
@@ -648,18 +649,7 @@ system administrator.")
"")
(("^install: (.*)install-sudoers(.*)" _ before after)
;; Don't try to create /etc/sudoers.
- (string-append "install: " before after "\n")))
-
- ;; XXX FIXME sudo 1.8.10p3 was bootstrapped with a
- ;; prerelease libtool, which fails on MIPS in the absence
- ;; of /usr/bin/file. As a temporary workaround, we patch
- ;; the configure script to hardcode use of the little
- ;; endian N32 ABI on MIPS.
- ,@(if (equal? "mips64el-linux" (or (%current-target-system)
- (%current-system)))
- '((substitute* "configure"
- (("\\$emul") "elf32ltsmipn32")))
- '()))
+ (string-append "install: " before after "\n"))))
%standard-phases)
;; XXX: The 'testsudoers' test series expects user 'root' to exist, but
@@ -669,6 +659,12 @@ system administrator.")
`(("groff" ,groff)
("linux-pam" ,linux-pam)
("coreutils" ,coreutils)))
+ (native-inputs
+ `(;; 'file' is needed by the pre-release libtool on MIPS.
+ ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+ (%current-system)))
+ `(("file" ,file))
+ '())))
(home-page "http://www.sudo.ws/")
(synopsis "Run commands as root")
(description