summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm87
1 files changed, 48 insertions, 39 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5e4b873d4e..fde09b001b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -491,8 +491,8 @@ allow automatic login and starting any app.")
(output (assoc-ref %outputs "out"))
(etc (string-append output "/etc")))
(setenv "PATH" (string-append xz "/bin"))
- (system* (string-append tar "/bin/tar") "xvf"
- source)
+ (invoke (string-append tar "/bin/tar") "xvf"
+ source)
(chdir ,(string-append "netbase-" version))
(mkdir-p etc)
(for-each copy-file
@@ -608,10 +608,10 @@ connection alive.")
(define-public isc-dhcp
(let* ((bind-major-version "9")
- (bind-minor-version "9")
- (bind-patch-version "11")
- (bind-release-type "-P") ; for patch release, use "-P"
- (bind-release-version "1") ; for patch release, e.g. "6"
+ (bind-minor-version "11")
+ (bind-patch-version "3")
+ (bind-release-type "") ; for patch release, use "-P"
+ (bind-release-version "") ; for patch release, e.g. "6"
(bind-version (string-append bind-major-version
"."
bind-minor-version
@@ -621,14 +621,14 @@ connection alive.")
bind-release-version)))
(package
(name "isc-dhcp")
- (version "4.3.6-P1")
+ (version "4.4.1")
(source (origin
(method url-fetch)
(uri (string-append "http://ftp.isc.org/isc/dhcp/"
version "/dhcp-" version ".tar.gz"))
(sha256
(base32
- "1hx3az6ckvgvybr1ag4k9kqr8zfcpzcww4vpw5gz0mi8y2z7gl9g"))))
+ "025nfqx4zwdgv4b3rkw26ihcj312vir08jk6yi57ndmb4a4m08ia"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f
@@ -674,16 +674,16 @@ connection alive.")
sh " SHELL=" sh))))
(let ((bind-directory (string-append "bind-" ,bind-version)))
- (system* "tar" "xf" "bind.tar.gz")
+ (invoke "tar" "xf" "bind.tar.gz")
(for-each patch-shebang
(find-files bind-directory ".*"))
- (zero? (system* "tar" "cf" "bind.tar.gz"
- bind-directory
- ;; avoid non-determinism in the archive
- "--sort=name"
- "--mtime=@0"
- "--owner=root:0"
- "--group=root:0"))))))
+ (invoke "tar" "cf" "bind.tar.gz"
+ bind-directory
+ ;; avoid non-determinism in the archive
+ "--sort=name"
+ "--mtime=@0"
+ "--owner=root:0"
+ "--group=root:0")))))
(add-after 'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Install the dhclient script for GNU/Linux and make sure
@@ -709,7 +709,8 @@ connection alive.")
,(map (lambda (dir)
(string-append dir "/bin:"
dir "/sbin"))
- (list inetutils net-tools coreutils sed))))))))))
+ (list inetutils net-tools coreutils sed))))
+ #t))))))
(native-inputs `(("perl" ,perl)))
@@ -727,7 +728,7 @@ connection alive.")
"/bind-" bind-version ".tar.gz"))
(sha256
(base32
- "1a4g6nzzrbmhngdgvgv1jjq4fm06m8fwc2a0gskkchplxl7dva20"))))
+ "1xbnb2b11274z9frc9y7nvkyxr52qx09bwb97gf9qzzcn8adx78d"))))
;; When cross-compiling, we need the cross Coreutils and sed.
;; Otherwise just use those from %FINAL-INPUTS.
@@ -742,7 +743,7 @@ connection alive.")
"ISC's Dynamic Host Configuration Protocol (DHCP) distribution provides a
reference implementation of all aspects of DHCP, through a suite of DHCP
tools: server, client, and relay agent.")
- (license license:isc)
+ (license license:mpl2.0)
(properties '((cpe-name . "dhcp"))))))
(define-public libpcap
@@ -903,13 +904,15 @@ at once based on a Perl regular expression.")
"0751mb9l2f0jrk3vj6q8ilanifd121dliwk0c34g8k0dlzsv3kd7"))
(modules '((guix build utils)))
(snippet
- '(substitute* "Makefile.in"
- (("-o \\$\\{LOG_OWN\\} -g \\$\\{LOG_GROUP\\}")
- ;; Don't try to chown root.
- "")
- (("mkdir -p \\$\\(ROTT_STATDIR\\)")
- ;; Don't attempt to create /var/lib/rottlog.
- "true")))))
+ '(begin
+ (substitute* "Makefile.in"
+ (("-o \\$\\{LOG_OWN\\} -g \\$\\{LOG_GROUP\\}")
+ ;; Don't try to chown root.
+ "")
+ (("mkdir -p \\$\\(ROTT_STATDIR\\)")
+ ;; Don't attempt to create /var/lib/rottlog.
+ "true"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list "ROTT_ETCDIR=/etc/rottlog" ;rc file location
@@ -973,7 +976,9 @@ system administrator.")
"0yg62wq8rcrbr7qvh3wgfg2g4bwanbi50cr2lf2cfyy8dydx4qyq"))
(modules '((guix build utils)))
(snippet
- '(delete-file-recursively "lib/zlib"))))
+ '(begin
+ (delete-file-recursively "lib/zlib")
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -1412,9 +1417,11 @@ environment variable is set and output is to tty.")
(base32
"1nwvjmx7kb14ni34c0b8x9a3791pc20gvhj7xaj66d8q4h6n0qf4"))
(modules '((guix build utils)))
- (snippet '(substitute* "tests/testsuite"
- (("#![[:blank:]]?/bin/sh")
- "#!$SHELL")))))
+ (snippet '(begin
+ (substitute* "tests/testsuite"
+ (("#![[:blank:]]?/bin/sh")
+ "#!$SHELL"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -1834,14 +1841,14 @@ done with the @code{auditctl} utility.")
(modules '((guix build utils)))
(snippet
'(begin
- (map delete-file-recursively
- ;; Remove bundled lua, pcap, and pcre libraries.
- ;; FIXME: Remove bundled liblinear once packaged.
- '("liblua"
- "libpcap"
- "libpcre"
- ;; Remove pre-compiled binares.
- "mswin32"))
+ (for-each delete-file-recursively
+ ;; Remove bundled lua, pcap, and pcre libraries.
+ ;; FIXME: Remove bundled liblinear once packaged.
+ '("liblua"
+ "libpcap"
+ "libpcre"
+ ;; Remove pre-compiled binares.
+ "mswin32"))
#t))))
(build-system gnu-build-system)
(inputs
@@ -2146,7 +2153,9 @@ Kerberos and Heimdal and FAST is supported with recent MIT Kerberos.")
(snippet
;; Remove binaries contained in the tarball which are only for the
;; target and can be regenerated anyway.
- '(delete-file-recursively "bin"))
+ '(begin
+ (delete-file-recursively "bin")
+ #t))
(file-name (string-append name "-" version ".tar.gz"))))
(native-inputs
`(("pkg-config" ,pkg-config)