summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm55
1 files changed, 51 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 06bc566cc7..db3e881228 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -784,7 +784,7 @@ memory, disks, network and processes. It's a Python port and continuation of
(define-public pies
(package
(name "pies")
- (version "1.7")
+ (version "1.8")
(source
(origin
(method url-fetch)
@@ -792,7 +792,16 @@ memory, disks, network and processes. It's a Python port and continuation of
version ".tar.bz2"))
(sha256
(base32
- "0ajcah2y6n55qc0ckspcx0hfpm1yb2xa1apcyij7mclic4q2y330"))))
+ "0v0xcq0mfil440xq2pa5mjkyva5c9ahqda54z5w2ksl2d78v8a35"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (for-each delete-file
+ (append
+ ;; Generated by flex.
+ (find-files "gres/src" "lex\\.c$")
+ ;; Generated by bison.
+ (find-files "gres/src" "-gram\\.[ch]$")))))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -804,6 +813,7 @@ memory, disks, network and processes. It's a Python port and continuation of
(substitute* '("src/progman.c" "src/comp.c")
(("\"/bin/sh\"")
(string-append "\"" bash "/bin/sh\"")))))))))
+ (native-inputs (list bison flex))
(home-page "https://www.gnu.org.ua/software/pies/")
(synopsis "Program invocation and execution supervisor")
(description
@@ -4193,7 +4203,7 @@ Python loading in HPC environments.")
(let ((real-name "inxi"))
(package
(name "inxi-minimal")
- (version "3.3.19-1")
+ (version "3.3.20-1")
(source
(origin
(method git-fetch)
@@ -4202,7 +4212,7 @@ Python loading in HPC environments.")
(commit version)))
(file-name (git-file-name real-name version))
(sha256
- (base32 "0g5m43cj4534gb181zy1hwjz5il88xibf8psxw8a4s6jnaq1zdlk"))))
+ (base32 "182lczpa217gpzn58nfdzjbbinp3bw9lbm1x9lck1mkdmqklgl2a"))))
(build-system trivial-build-system)
(inputs
`(("bash" ,bash-minimal)
@@ -5444,3 +5454,40 @@ attempts, it cannot eliminate the risk presented by weak authentication. Set
up services to use only two factor, or public/private authentication
mechanisms if you really want to protect services.")
(license license:gpl2+)))
+
+(define-public rex
+ (package
+ (name "rex")
+ (version "4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.gnu.org.ua/pub/releases/rex/rex-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1arb8z602invwavskq36nhwy42a3v14iyhi06iqlngfai2k93fai"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; No configure script and Makefile.
+ (delete 'configure)
+ (delete 'build)
+ (add-before 'install 'patch-exec-expect
+ (lambda _
+ (substitute* "rex"
+ (("exec expect") (string-append "exec " (which "expect"))))))
+ (replace 'install
+ (lambda _
+ (invoke "./install"
+ (string-append "--prefix=" #$output)))))))
+ (inputs (list expect))
+ (home-page "https://www.gnu.org.ua/software/rex/")
+ (synopsis "Remote execution utility")
+ (description "@command{rex} runs a supplied command or shell script on
+several hosts in succession or in parallel. It can also be used to copy a
+file or files to several hosts.")
+ (license license:gpl3+)))