summaryrefslogtreecommitdiff
path: root/gnu/packages/agda.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/agda.scm')
-rw-r--r--gnu/packages/agda.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index 4dd6366247..038b38195f 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2018 Alex ter Weele <alex.ter.weele@gmail.com>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 John Soo <jsoo1@asu.edu>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;;
@@ -29,6 +29,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
#:use-module (guix build-system trivial)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -37,7 +38,7 @@
(define-public agda
(package
(name "agda")
- (version "2.6.2.1")
+ (version "2.6.2.2")
(source
(origin
(method url-fetch)
@@ -45,7 +46,7 @@
"https://hackage.haskell.org/package/Agda/Agda-"
version ".tar.gz"))
(sha256
- (base32 "03dw7jfqr3ffik6avigm525djqh2gn5c3qwnb2h6298zkr9lch9w"))))
+ (base32 "0yjjbhc593ylrm4mq4j01nkdvh7xqsg5in30wxj4y53vf5hkggp5"))))
(build-system haskell-build-system)
(inputs
(list ghc-aeson
@@ -71,22 +72,22 @@
ghc-uri-encode
ghc-zlib))
(arguments
- `(#:modules ((guix build haskell-build-system)
- (guix build utils)
- (srfi srfi-26)
- (ice-9 match))
- #:phases
- (modify-phases %standard-phases
- ;; This allows us to call the 'agda' binary before installing.
- (add-after 'unpack 'set-ld-library-path
- (lambda _
- (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/dist/build"))))
- (add-after 'compile 'agda-compile
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (agda-compiler (string-append out "/bin/agda")))
- (for-each (cut invoke agda-compiler <>)
- (find-files (string-append out "/share") "\\.agda$"))))))))
+ (list #:modules `((guix build haskell-build-system)
+ (guix build utils)
+ (srfi srfi-26)
+ (ice-9 match))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; This allows us to call the 'agda' binary before installing.
+ (add-after 'unpack 'set-ld-library-path
+ (lambda _
+ (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/dist/build"))))
+ (add-after 'compile 'agda-compile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((agda-compiler (string-append #$output "/bin/agda")))
+ (for-each (cut invoke agda-compiler <>)
+ (find-files (string-append #$output "/share")
+ "\\.agda$"))))))))
(home-page "https://wiki.portal.chalmers.se/agda/")
(synopsis
"Dependently typed functional programming language and proof assistant")