summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm89
1 files changed, 45 insertions, 44 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index ff6e5189fd..439b3b2946 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1,13 +1,13 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2015, 2017, 2018, 2021 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016–2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2019, 2021 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2017, 2019, 2021, 2022 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
@@ -69,6 +69,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system r)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix hg-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -328,7 +329,7 @@ precision.")
(define-public giac
(package
(name "giac")
- (version "1.7.0-45")
+ (version "1.7.0-51")
(source
(origin
(method url-fetch)
@@ -340,42 +341,42 @@ precision.")
"~parisse/debian/dists/stable/main/source/"
"giac_" version ".tar.gz"))
(sha256
- (base32 "19hxbx27n5zby96d4pzhxxqn7mzk29g8sxn08fi638l17lr9x2q2"))))
+ (base32 "0wgqa2nxpv652348fxpchx5zvaj6ssc403jxwsdp5ky9pdpap2zs"))))
(build-system gnu-build-system)
(arguments
- `(#:modules ((ice-9 ftw)
+ (list
+ #:modules '((ice-9 ftw)
(guix build utils)
(guix build gnu-build-system))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-bin-cp
- ;; Some Makefiles contain hard-coded "/bin/cp".
- (lambda _
- (substitute* (cons "micropython-1.12/xcas/Makefile"
- (find-files "doc" "^Makefile"))
- (("/bin/cp") (which "cp")))))
- (add-after 'unpack 'disable-failing-test
- ;; FIXME: Test failing. Not sure why.
- (lambda _
- (substitute* "check/Makefile.in"
- (("chk_fhan11") ""))))
- (add-after 'install 'fix-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; Most French documentation has a non-commercial
- ;; license, so we need to remove it.
- (with-directory-excursion (string-append out "/share/giac/doc/fr")
- (for-each delete-file-recursively
- '("cascas" "casexo" "casgeo" "casrouge" "cassim"
- "castor")))
- ;; Remove duplicate documentation in
- ;; "%out/share/doc/giac/", where Xcas does not expect
- ;; to find it.
- (delete-file-recursively (string-append out "/share/doc/giac")))))
- (add-after 'install 'remove-unnecessary-executable
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (delete-file (string-append out "/bin/xcasnew"))))))))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-bin-cp
+ ;; Some Makefiles contain hard-coded "/bin/cp".
+ (lambda _
+ (substitute* (cons "micropython-1.12/xcas/Makefile"
+ (find-files "doc" "^Makefile"))
+ (("/bin/cp") (which "cp")))))
+ (add-after 'unpack 'disable-failing-test
+ ;; FIXME: Test failing. Not sure why.
+ (lambda _
+ (substitute* "check/Makefile.in"
+ (("chk_fhan11") ""))))
+ (add-after 'install 'fix-doc
+ (lambda _
+ ;; Most French documentation has a non-commercial license, so we
+ ;; need to remove it.
+ (with-directory-excursion
+ (string-append #$output "/share/giac/doc/fr")
+ (for-each delete-file-recursively
+ '("cascas" "casexo" "casgeo" "casrouge" "cassim"
+ "castor")))
+ ;; Remove duplicate documentation in "%out/share/doc/giac/",
+ ;; where Xcas does not expect to find it.
+ (delete-file-recursively
+ (string-append #$output "/share/doc/giac"))))
+ (add-after 'install 'remove-unnecessary-executable
+ (lambda _
+ (delete-file (string-append #$output "/bin/xcasnew")))))))
(inputs
;; TODO: Add libnauty, unbundle "libmicropython.a".
(list ao
@@ -1139,7 +1140,7 @@ features, and more.")
(define-public xtensor
(package
(name "xtensor")
- (version "0.20.10")
+ (version "0.24.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1147,11 +1148,11 @@ features, and more.")
(commit version)))
(sha256
(base32
- "1fmv2hpx610xwhxrndfsfvlbqfyk4l3gi5q5d7pa9m82kblxjj9l"))
+ "14fpzwdq26p2fqdrmc78hny9pp09k9c53jnwlh7f8x54ikzm23c2"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
- (list googletest xtl))
+ (list doctest googletest xtl))
(arguments
`(#:configure-flags
'("-DBUILD_TESTS=ON")
@@ -1181,7 +1182,7 @@ xtensor provides:
(add-after 'unpack 'remove-march=native
(lambda _
(substitute* "benchmark/CMakeLists.txt"
- (("-march=native") ""))))
+ (("-march=native\"") "\""))))
(add-after 'unpack 'link-with-googlebenchmark
(lambda _
(substitute* "benchmark/CMakeLists.txt"
@@ -1348,14 +1349,14 @@ objects.")
(define-public gappa
(package
(name "gappa")
- (version "1.3.5")
+ (version "1.4.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://gforge.inria.fr/frs/download.php/latestfile/"
- "2699/gappa-" version ".tar.gz"))
+ (uri (string-append "https://gappa.gitlabpages.inria.fr/releases/"
+ "gappa-" version ".tar.gz"))
(sha256
(base32
- "0q1wdiwqj6fsbifaayb1zkp20bz8a1my81sqjsail577jmzwi07w"))))
+ "12x42z901pr05ldmparqdi8sq9s7fxbavhzk2dbq3l6hy247dwbb"))))
(build-system gnu-build-system)
(inputs
(list boost gmp mpfr))
@@ -1382,7 +1383,7 @@ filters for CGAL and it is used to certify elementary functions in CRlibm.
While Gappa is intended to be used directly, it can also act as a backend
prover for the Why3 software verification platform or as an automatic tactic
for the Coq proof assistant.")
- (license (list license:gpl3+ license:cecill-c)))) ; either/or
+ (license (list license:gpl3+ license:cecill)))) ; either/or
(define-public givaro
(package