summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 07dfaafdc3..fb3b3e94b3 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -399,7 +399,11 @@ cosine/ sine transforms or DCT/DST).")
;; anyway, so just skip them.
'(substitute* "CMakeLists.txt"
(("add_subdirectory\\(unsupported\\)")
- "# Do not build the tests for unsupported features.\n")))))
+ "# Do not build the tests for unsupported features.\n")
+ ;; Work around
+ ;; <http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1114>.
+ (("\"include/eigen3\"")
+ "\"${CMAKE_INSTALL_PREFIX}/include/eigen3\"")))))
(build-system cmake-build-system)
(arguments
'(;; Turn off debugging symbols to save space.