summaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 2425d1cbec..ede217078f 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -38,6 +38,16 @@
(base32
"1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-aspell
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin/aspell (string-append (assoc-ref outputs "out")
+ "/bin/aspell")))
+ (wrap-program bin/aspell
+ '("ASPELL_CONF" "" =
+ ("${ASPELL_CONF:-\"dict-dir ${GUIX_PROFILE:-$HOME/.guix-profile}/lib/aspell\"}")))))))))
(inputs `(("perl" ,perl)))
(home-page "http://aspell.net/")
(synopsis "Spell checker")