summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6e8e2e3ebb..e9e924a836 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -713,6 +713,35 @@ extensions into easy to use C++ classes. It is the successor of
lv2-c++-tools.")
(license license:gpl3+)))
+(define-public openal
+ (package
+ (name "openal")
+ (version "1.15.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://kcat.strangesoft.net/openal-releases/openal-soft-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0mmhdqiyb3c9dzvxspm8h2v8jibhi8pfjxnf6m0wn744y1ia2a8f"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no check target
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("pulseaudio" ,pulseaudio)))
+ (synopsis "3D audio API")
+ (description
+ "OpenAL provides capabilities for playing audio in a virtual 3D
+environment. Distance attenuation, doppler shift, and directional sound
+emitters are among the features handled by the API. More advanced effects,
+including air absorption, occlusion, and environmental reverb, are available
+through the EFX extension. It also facilitates streaming audio, multi-channel
+buffers, and audio capture.")
+ (home-page "http://kcat.strangesoft.net/openal.html")
+ (license license:lgpl2.0+)))
+
(define-public patchage
(package
(name "patchage")