summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 1d6277c125..3491f1cdd2 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1488,6 +1488,30 @@ to record and/or play sound using a callback function or a blocking read/write
interface.")
(license license:expat)))
+(define-public qsynth
+ (package
+ (name "qsynth")
+ (version "0.3.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/qsynth/qsynth-" version ".tar.gz"))
+ (sha256
+ (base32 "08kyn6cl755l9i1grzjx8yi3f8mgiz4gx0hgqad1n0d8yz85087b"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; no "check" phase
+ (inputs
+ `(("qt" ,qt)
+ ("fluidsynth" ,fluidsynth)))
+ (home-page "http://qsynth.sourceforge.net")
+ (synopsis "Graphical user interface for FluidSynth")
+ (description
+ "Qsynth is a GUI front-end application for the FluidSynth SoundFont
+synthesizer written in C++.")
+ (license license:gpl2+)))
+
(define-public rsound
(package
(name "rsound")