summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm26
1 files changed, 9 insertions, 17 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3168a97414..7024c46bb5 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages qt)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages linux)
@@ -1683,7 +1684,12 @@ to be plugged into a wide range of audio synthesis and recording packages.")
"12z1vx3krrzsfccpah9xjs68900xvr7bw92wx8np5871i2yv47iw"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ '(;; Glibc no longer includes Sun RPC support, so tell the build system
+ ;; to use libtirpc instead.
+ #:make-flags (list (string-append "CFLAGS=-I"
+ (assoc-ref %build-inputs "libtirpc")
+ "/include/tirpc -ltirpc"))
+ #:phases
(modify-phases %standard-phases
;; lashd embeds an ancient version of sigsegv so we just skip it
(add-after 'unpack 'skip-lashd
@@ -1696,6 +1702,7 @@ to be plugged into a wide range of audio synthesis and recording packages.")
`(("bdb" ,bdb)
("gtk" ,gtk+-2)
("jack" ,jack-1)
+ ("libtirpc" ,libtirpc)
("readline" ,readline)
("python" ,python-2)))
;; According to pkg-config, packages depending on lash also need to have
@@ -1948,22 +1955,7 @@ software.")
#:configure-flags
(list (string-append "--boost-includes="
(assoc-ref %build-inputs "boost")
- "/include"))
- #:phases (modify-phases %standard-phases
- (add-before
- 'configure 'set-flags
- (lambda* (#:key inputs #:allow-other-keys)
- ;; See e.g. https://github.com/lvtk/lvtk/issues/21
- (setenv "LDFLAGS"
- (string-append
- "-L" (assoc-ref inputs "boost") "/lib "
- "-lboost_system"))
- ;; Needed for gtkmm
- (substitute* '("src/wscript_build"
- "examples/wscript_build")
- (("cxxflags.*= \\[" line)
- (string-append line "\"-std=c++11\", ")))
- #t)))))
+ "/include"))))
(inputs
`(("boost" ,boost)
("gtkmm" ,gtkmm-2)