summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ebae5d57d9..3cc5cebc2c 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -320,7 +320,8 @@ tools (analyzer, mono/stereo tools, crossovers).")
version "/Csound" version ".tar.gz"))
(sha256
(base32
- "0a1sni6lr7qpwywpggbkp0ia3h9bwwgf9i87gsag8ra2h30v82hd"))))
+ "0a1sni6lr7qpwywpggbkp0ia3h9bwwgf9i87gsag8ra2h30v82hd"))
+ (patches (list (search-patch "csound-header-ordering.patch")))))
(build-system cmake-build-system)
(arguments
;; Work around this error on x86_64 with libc 2.22+:
@@ -1081,7 +1082,16 @@ software.")
#:configure-flags
(list (string-append "--boost-includes="
(assoc-ref %build-inputs "boost")
- "/include"))))
+ "/include"))
+ #:phases (modify-phases %standard-phases
+ (add-before
+ 'configure 'set-flags
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; See e.g. https://github.com/lvtk/lvtk/issues/21
+ (setenv "LDFLAGS"
+ (string-append
+ "-L" (assoc-ref inputs "boost") "/lib "
+ "-lboost_system")))))))
(inputs
`(("boost" ,boost)
("lv2" ,lv2)))