summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 203ff4c9dc..a503b06603 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -66,8 +66,7 @@
"duplicity-test_selection-tmp.patch"))))
(build-system python-build-system)
(native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ("util-linux" ,util-linux))) ;setsid command, for the tests
+ `(("util-linux" ,util-linux))) ;setsid command, for the tests
(inputs
`(("python" ,python-2)
("librsync" ,librsync)
@@ -339,8 +338,6 @@ errors.")
(base32
"1nwmmh816f96h0ff1jxk95ad38ilbhbdl5dgibx1d4cl81dsi48d"))))
(build-system python-build-system)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)))
(inputs
`(("python" ,python-2)
("librsync" ,librsync)))
@@ -438,7 +435,9 @@ detection, and lossless compression.")
;; The tests need to be run after Borg is installed.
(delete 'check)
(add-after 'install 'check
- (lambda _
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make the installed package available for the test suite.
+ (add-installed-pythonpath inputs outputs)
(zero?
(system* "py.test" "-v" "--pyargs" "borg.testsuite" "-k"
(string-append
@@ -451,7 +450,13 @@ detection, and lossless compression.")
"and not test_default_acl "
"and not test_non_ascii_acl "
;; This test needs the unpackaged pytest-benchmark.
- "and not benchmark")))))
+ "and not benchmark "
+ ;; These tests assume the kernel supports FUSE. They
+ ;; were skipped using the "old" Python build system,
+ ;; before commit
+ ;; 7db40bce58e149ecb541d295e01cfbfe953d39a3.
+ "and not test_fuse "
+ "and not test_fuse_allow_damaged_files")))))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))