summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 6dc9e97c34..e896dbe2e1 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -670,10 +670,13 @@ store.")
;; TODO: Move the patch to 'patches' in the next update cycle.
,@(if (string-prefix? "i686" (or (%current-target-system)
(%current-system)))
- `(zero? (system* "patch" "-p1" "--force"
- "--input"
- (assoc-ref native-inputs
- "glibc-memchr-overflow-i686.patch")))
+ `((unless (zero? (system* "patch" "-p1" "--force"
+ "--input"
+ (or (assoc-ref native-inputs
+ "glibc-memchr-overflow-i686.patch")
+ (assoc-ref inputs
+ "glibc-memchr-overflow-i686.patch"))))
+ (error "patch failed for glibc-memchr-overflow-i686.patch")))
'())
;; Have `system' use that Bash.