summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm56
1 files changed, 20 insertions, 36 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 554e848369..ca440c242c 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -148,18 +148,16 @@ standard utility.")
(define-public patch
(package
(name "patch")
- (version "2.7.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/patch/patch-"
- version ".tar.xz"))
- (sha256
- (base32
- "1sqckf560pzwgniy00vcpdv2c9c11s4cmhlm14yqgg8avd3bl94i"))))
+ (version "2.7.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/patch/patch-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "02gikxjvcxysr4l65c8vivgz62xmalp0av5ypzff8vqhrq3vpb0f"))))
(build-system gnu-build-system)
(native-inputs `(("ed", ed)))
- ;; TODO: When cross-compiling, add this:
- ;; '(#:configure-flags '("ac_cv_func_strnlen_working=yes"))
(synopsis "Apply differences to originals, with optional backups")
(description
"Patch is a program that applies changes to files based on differences
@@ -168,27 +166,8 @@ files depending on the contents of the diff file. It accepts several
different diff formats. It may also be used to revert previously applied
differences.")
(license gpl3+)
- (replacement patch-CVE-2015-1196)
(home-page "http://savannah.gnu.org/projects/patch/")))
-(define-public patch-2.7.4
- (package
- (inherit patch)
- (version "2.7.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/patch/patch-"
- version ".tar.xz"))
- (sha256
- (base32
- "02gikxjvcxysr4l65c8vivgz62xmalp0av5ypzff8vqhrq3vpb0f"))))
- (replacement #f)))
-
-(define patch-CVE-2015-1196
- (package (inherit patch-2.7.4)
- ;; Keep the old version number so it can be used as a 'replacement'.
- (version (package-version patch))))
-
(define-public diffutils
(package
(name "diffutils")
@@ -379,14 +358,14 @@ included.")
(define-public glibc
(package
(name "glibc")
- (version "2.20")
+ (version "2.21")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/glibc/glibc-"
version ".tar.xz"))
(sha256
(base32
- "19bbyfc2gcxr9rihrkkbd3p362i608yhlyrr7icqsa6cmr16sjzq"))
+ "1f135546j34s9bfkydmx2nhh9vwxlx60jldi80zmsnln6wj3dsxf"))
(snippet
;; Disable 'ldconfig' and /etc/ld.so.cache. The latter is
;; required on LFS distros to avoid loading the distro's libc.so
@@ -395,10 +374,7 @@ included.")
(("use_ldconfig=yes")
"use_ldconfig=no")))
(modules '((guix build utils)))
- (patches (list (search-patch "glibc-CVE-2014-7817.patch")
- (search-patch "glibc-CVE-2012-3406.patch")
- (search-patch "glibc-mips-dangling-vfork-ref.patch")
- (search-patch "glibc-ldd-x86_64.patch")))))
+ (patches (list (search-patch "glibc-ldd-x86_64.patch")))))
(build-system gnu-build-system)
;; Glibc's <limits.h> refers to <linux/limit.h>, for instance, so glibc
@@ -431,7 +407,7 @@ included.")
(assoc-ref %build-inputs "linux-headers")
"/include")
- ;; This is the default for most architectures as of GNU libc 2.20,
+ ;; This is the default for most architectures as of GNU libc 2.21,
;; but we specify it explicitly for clarity and consistency. See
;; "kernel-features.h" in the GNU libc for details.
"--enable-kernel=2.6.32"
@@ -510,6 +486,13 @@ included.")
(native-inputs `(("texinfo" ,texinfo)
("perl" ,perl)))
+ (native-search-paths
+ ;; Search path for packages that provide locale data. This is useful
+ ;; primarily in build environments.
+ (list (search-path-specification
+ (variable "LOCPATH")
+ (files '("share/locale")))))
+
(synopsis "The GNU C Library")
(description
"Any Unix-like operating system needs a C library: the library which
@@ -534,6 +517,7 @@ with the Linux kernel.")
more than 400 in total. To use them set the 'LOCPATH' environment variable to
the 'share/locale' sub-directory of this package.")
(outputs '("out")) ;110+ MiB
+ (native-search-paths '())
(arguments
(let ((args `(#:tests? #f #:strip-binaries? #f
,@(package-arguments glibc))))