summaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm39
1 files changed, 33 insertions, 6 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index df2be86424..acaeb67079 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,12 +22,14 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages compression)
- #:use-module (gnu packages linux))
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages python))
(define-public fio
(package
(name "fio")
- (version "2.16")
+ (version "2.17")
(source (origin
(method url-fetch)
(uri (string-append
@@ -35,22 +37,47 @@
"fio-" version ".tar.bz2"))
(sha256
(base32
- "1v5n5hq500aidwfzmbm3k5d3mhh6ffwbgzq7nys838azga4xd3bx"))))
+ "1kxgad5k2m7y637g3kq8jmhwzlg3c64w9ky7066c5l09bwb6l58h"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; No tests.
#:phases
(modify-phases %standard-phases
+ (add-after
+ 'unpack 'patch-paths
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gnuplot (string-append (assoc-ref inputs "gnuplot")
+ "/bin/gnuplot")))
+ (substitute* "tools/plot/fio2gnuplot"
+ (("/usr/share/fio") (string-append out "/share/fio"))
+ ;; FIXME (upstream): The 'gnuplot' executable is used inline
+ ;; in various os.system() calls mixed with *.gnuplot filenames.
+ (("; do gnuplot") (string-append "; do " gnuplot))
+ (("gnuplot mymath") (string-append gnuplot " mymath"))
+ (("gnuplot mygraph") (string-append gnuplot " mygraph")))
+ #t)))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
;; The configure script doesn't understand some of the
;; GNU options, so we can't use #:configure-flags.
(let ((out (assoc-ref outputs "out")))
(zero? (system* "./configure"
- (string-append "--prefix=" out)))))))))
+ (string-append "--prefix=" out))))))
+ (add-after
+ 'install 'wrap-python-scripts
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/fiologparser_hist.py")
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))
+ #t))))))
(inputs
`(("libaio" ,libaio)
- ("zlib" ,zlib)))
+ ("gnuplot" ,gnuplot)
+ ("zlib" ,zlib)
+ ("python-numpy" ,python2-numpy)
+ ("python-pandas" ,python2-pandas)
+ ("python" ,python-2)))
(home-page "https://github.com/axboe/fio")
(synopsis "Flexible I/O tester")
(description