summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm477
1 files changed, 462 insertions, 15 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d611f3a491..6b5c0a0391 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
;;; Copyright © 2020, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -927,6 +928,26 @@ All datasets are restricted to protein coding genes.")
from Illumina 450k methylation arrays.")
(license license:artistic2.0)))
+(define-public r-chromstardata
+ (package
+ (name "r-chromstardata")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "chromstaRData" version 'experiment))
+ (sha256
+ (base32
+ "0ph80d53598635bb8g61acg5rqwnj8644a0gh297r4hgbvwlflab"))))
+ (properties `((upstream-name . "chromstaRData")))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/chromstaRData/")
+ (synopsis "ChIP-seq data for demonstration purposes")
+ (description
+ "This package provides ChIP-seq data for demonstration purposes in the
+chromstaR package.")
+ (license license:gpl3)))
+
(define-public r-genelendatabase
(package
(name "r-genelendatabase")
@@ -1066,7 +1087,7 @@ package @code{affy}.")
(properties `((upstream-name . "gageData")))
(build-system r-build-system)
(home-page "https://bioconductor.org/packages/gageData")
- (synopsis "Auxillary data for gage package")
+ (synopsis "Auxiliary data for the gage package")
(description
"This is a supportive data package for the software package @code{gage}.
However, the data supplied here are also useful for gene set or pathway
@@ -1212,6 +1233,39 @@ data. In addition, provides numerous plotting functions for commonly
used visualizations.")
(license license:artistic2.0)))
+(define-public r-delayedarray
+ (package
+ (name "r-delayedarray")
+ (version "0.16.3")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DelayedArray" version))
+ (sha256
+ (base32
+ "0w1wppy6m2iv41852dscg3y19sq84ahdx3m7c2p2pxjcznmv6hys"))))
+ (properties
+ `((upstream-name . "DelayedArray")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-iranges" ,r-iranges)
+ ("r-matrix" ,r-matrix)
+ ("r-matrixgenerics" ,r-matrixgenerics)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/DelayedArray")
+ (synopsis "Delayed operations on array-like objects")
+ (description
+ "Wrapping an array-like object (typically an on-disk object) in a
+@code{DelayedArray} object allows one to perform common array operations on it
+without loading the object in memory. In order to reduce memory usage and
+optimize performance, operations on the object are either delayed or executed
+using a block processing mechanism. Note that this also works on in-memory
+array-like objects like @code{DataFrame} objects (typically with Rle columns),
+@code{Matrix} objects, and ordinary arrays and data frames.")
+ (license license:artistic2.0)))
+
(define-public r-bluster
(package
(name "r-bluster")
@@ -1294,6 +1348,60 @@ naming and share the same rich and consistent \"Vector API\" as much as
possible.")
(license license:artistic2.0)))
+;; This is a CRAN package, but it depends on r-biobase and r-limma from Bioconductor.
+(define-public r-absfiltergsea
+ (package
+ (name "r-absfiltergsea")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "AbsFilterGSEA" version))
+ (sha256
+ (base32 "15srxkxsvn38kd5frdrwfdf0ad8gskrd0h01wmdf9hglq8fjrp7w"))))
+ (properties `((upstream-name . "AbsFilterGSEA")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-deseq" ,r-deseq)
+ ("r-limma" ,r-limma)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page "https://cran.r-project.org/web/packages/AbsFilterGSEA/")
+ (synopsis "Improved false positive control of gene-permuting with absolute filtering")
+ (description
+ "This package provides a function that performs gene-permuting of a gene-set
+enrichment analysis (GSEA) calculation with or without the absolute filtering.
+ Without filtering, users can perform (original) two-tailed or one-tailed
+absolute GSEA.")
+ (license license:gpl2)))
+
+;; This is a CRAN package, but it depends on r-biobase from Bioconductor.
+(define-public r-bisquerna
+ (package
+ (name "r-bisquerna")
+ (version "1.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "BisqueRNA" version))
+ (sha256
+ (base32
+ "01g34n87ml7n3pck77497ddgbv3rr5p4153ac8ninpgjijlm3jw2"))))
+ (properties `((upstream-name . "BisqueRNA")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-limsolve" ,r-limsolve)))
+ (home-page "https://www.biorxiv.org/content/10.1101/669911v1")
+ (synopsis "Decomposition of bulk expression with single-cell sequencing")
+ (description "This package provides tools to accurately estimate cell type
+abundances from heterogeneous bulk expression. A reference-based method
+utilizes single-cell information to generate a signature matrix and
+transformation of bulk expression for accurate regression based estimates.
+A marker-based method utilizes known cell-specific marker genes to measure
+relative abundances across samples.")
+ (license license:gpl3)))
+
;; This is a CRAN package, but it depends on r-bsgenome-hsapiens-ucsc-hg19
;; from Bioconductor.
(define-public r-deconstructsigs
@@ -1538,6 +1646,35 @@ structure.")
microarrays.")
(license license:artistic2.0)))
+(define-public r-annotationdbi
+ (package
+ (name "r-annotationdbi")
+ (version "1.52.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AnnotationDbi" version))
+ (sha256
+ (base32
+ "0zqxgh3nx6y8ry12s2vss2f4axz5vpqxha1y4ifhhcx4zhpzsglr"))))
+ (properties
+ `((upstream-name . "AnnotationDbi")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-dbi" ,r-dbi)
+ ("r-iranges" ,r-iranges)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-s4vectors" ,r-s4vectors)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/AnnotationDbi")
+ (synopsis "Annotation database interface")
+ (description
+ "This package provides user interface and database connection code for
+annotation data packages using SQLite data storage.")
+ (license license:artistic2.0)))
+
(define-public r-annotationforge
(package
(name "r-annotationforge")
@@ -1570,6 +1707,148 @@ microarrays.")
databases. Packages produced are intended to be used with AnnotationDbi.")
(license license:artistic2.0)))
+(define-public r-biobase
+ (package
+ (name "r-biobase")
+ (version "2.50.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Biobase" version))
+ (sha256
+ (base32
+ "11kgc4flywlm3i18603558l8ksv91c24vkc5fnnbcd375i2dhhd4"))))
+ (properties
+ `((upstream-name . "Biobase")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)))
+ (home-page "https://bioconductor.org/packages/Biobase")
+ (synopsis "Base functions for Bioconductor")
+ (description
+ "This package provides functions that are needed by many other packages
+on Bioconductor or which replace R functions.")
+ (license license:artistic2.0)))
+
+(define-public r-biomart
+ (package
+ (name "r-biomart")
+ (version "2.46.3")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "biomaRt" version))
+ (sha256
+ (base32
+ "0gwmd0ykpv0gyh34c56g5m12lil20fvig49f3ih1jxrxf3q4wmq7"))))
+ (properties
+ `((upstream-name . "biomaRt")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biocfilecache" ,r-biocfilecache)
+ ("r-httr" ,r-httr)
+ ("r-openssl" ,r-openssl)
+ ("r-progress" ,r-progress)
+ ("r-rappdirs" ,r-rappdirs)
+ ("r-stringr" ,r-stringr)
+ ("r-xml" ,r-xml)
+ ("r-xml2" ,r-xml2)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/biomaRt")
+ (synopsis "Interface to BioMart databases")
+ (description
+ "biomaRt provides an interface to a growing collection of databases
+implementing the @url{BioMart software suite, http://www.biomart.org}. The
+package enables retrieval of large amounts of data in a uniform way without
+the need to know the underlying database schemas or write complex SQL queries.
+Examples of BioMart databases are Ensembl, COSMIC, Uniprot, HGNC, Gramene,
+Wormbase and dbSNP mapped to Ensembl. These major databases give biomaRt
+users direct access to a diverse set of data and enable a wide range of
+powerful online queries from gene annotation to database mining.")
+ (license license:artistic2.0)))
+
+(define-public r-biocparallel
+ (package
+ (name "r-biocparallel")
+ (version "1.24.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BiocParallel" version))
+ (sha256
+ (base32
+ "1iryicvmcagcrj29kp49mqhiq2kn72j4idj380hi9illmdrg9ism"))))
+ (properties
+ `((upstream-name . "BiocParallel")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-reproducible
+ (lambda _
+ ;; Remove generated documentation.
+ (for-each delete-file
+ '("inst/doc/BiocParallel_BatchtoolsParam.pdf"
+ "inst/doc/Introduction_To_BiocParallel.pdf"
+ "inst/doc/Errors_Logs_And_Debugging.pdf"
+ "inst/doc/BiocParallel_BatchtoolsParam.R"
+ "inst/doc/Introduction_To_BiocParallel.R"
+ "inst/doc/Errors_Logs_And_Debugging.R"))
+
+ ;; Remove time-dependent macro
+ (substitute* '("inst/doc/BiocParallel_BatchtoolsParam.Rnw"
+ "inst/doc/Introduction_To_BiocParallel.Rnw"
+ "inst/doc/Errors_Logs_And_Debugging.Rnw"
+ "vignettes/BiocParallel_BatchtoolsParam.Rnw"
+ "vignettes/Introduction_To_BiocParallel.Rnw"
+ "vignettes/Errors_Logs_And_Debugging.Rnw")
+ (("\\today") "later"))
+
+ ;; Initialize the random number generator seed when building.
+ (substitute* "R/internal_rng_stream.R"
+ (("\"L'Ecuyer-CMRG\"\\)" m)
+ (string-append
+ m "; if (!is.na(Sys.getenv(\"SOURCE_DATE_EPOCH\"))) {set.seed(100)}\n"))))))))
+ (propagated-inputs
+ `(("r-futile-logger" ,r-futile-logger)
+ ("r-snow" ,r-snow)
+ ("r-bh" ,r-bh)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/BiocParallel")
+ (synopsis "Bioconductor facilities for parallel evaluation")
+ (description
+ "This package provides modified versions and novel implementation of
+functions for parallel evaluation, tailored to use with Bioconductor
+objects.")
+ (license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-biostrings
+ (package
+ (name "r-biostrings")
+ (version "2.58.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Biostrings" version))
+ (sha256
+ (base32
+ "1rbqhs73mhfr1gi0rx28jiyan7i3hb45ai3jpl1656fnrhgjfxq5"))))
+ (properties
+ `((upstream-name . "Biostrings")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-crayon" ,r-crayon)
+ ("r-iranges" ,r-iranges)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xvector" ,r-xvector)))
+ (home-page "https://bioconductor.org/packages/Biostrings")
+ (synopsis "String objects and algorithms for biological sequences")
+ (description
+ "This package provides memory efficient string containers, string
+matching algorithms, and other utilities, for fast manipulation of large
+biological sequences or sets of sequences.")
+ (license license:artistic2.0)))
+
(define-public r-category
(package
(name "r-category")
@@ -1743,13 +2022,13 @@ high-throughput sequencing experiments.")
(define-public r-genomeinfodb
(package
(name "r-genomeinfodb")
- (version "1.26.4")
+ (version "1.26.6")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "GenomeInfoDb" version))
(sha256
(base32
- "1sbhdpgabqbi749ixih8nlmq5id7sg8y6kkfj46r00642rc293ys"))))
+ "1wy4dwiv0pgim975var802z565py4a0nakx6zdvbhry4c0dfczd1"))))
(properties
`((upstream-name . "GenomeInfoDb")))
(build-system r-build-system)
@@ -1770,6 +2049,37 @@ translation between different chromosome sequence naming conventions (e.g.,
names in their natural, rather than lexicographic, order.")
(license license:artistic2.0)))
+(define-public r-genomicranges
+ (package
+ (name "r-genomicranges")
+ (version "1.42.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GenomicRanges" version))
+ (sha256
+ (base32
+ "0j4py5g6pdj35xhlaqhxxhg55j9l4mcdk3yck4dgyavv5f2dh24i"))))
+ (properties
+ `((upstream-name . "GenomicRanges")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-iranges" ,r-iranges)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xvector" ,r-xvector)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/GenomicRanges")
+ (synopsis "Representation and manipulation of genomic intervals")
+ (description
+ "This package provides tools to efficiently represent and manipulate
+genomic annotations and alignments is playing a central role when it comes to
+analyzing high-throughput sequencing data (a.k.a. NGS data). The
+GenomicRanges package defines general purpose containers for storing and
+manipulating genomic intervals and variables defined along a genome.")
+ (license license:artistic2.0)))
+
(define-public r-gostats
(package
(name "r-gostats")
@@ -1850,6 +2160,25 @@ Enrichment Analysis} (GSEA).")
the Human Protein Atlas project.")
(license license:artistic2.0)))
+(define-public r-limma
+ (package
+ (name "r-limma")
+ (version "3.46.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "limma" version))
+ (sha256
+ (base32
+ "1xxv493q1kip9bjfv7v7k5dnq7hz7gvl80i983v4mvwavhgnbxfz"))))
+ (build-system r-build-system)
+ (home-page "http://bioinf.wehi.edu.au/limma")
+ (synopsis "Package for linear models for microarray and RNA-seq data")
+ (description "This package can be used for the analysis of gene expression
+studies, especially the use of linear models for analysing designed experiments
+and the assessment of differential expression. The analysis methods apply to
+different technologies, including microarrays, RNA-seq, and quantitative PCR.")
+ (license license:gpl2+)))
+
(define-public r-rbgl
(package
(name "r-rbgl")
@@ -1954,6 +2283,49 @@ reports together for a particular project that can be viewed in a web
browser.")
(license license:artistic2.0)))
+(define-public r-rsamtools
+ (package
+ (name "r-rsamtools")
+ (version "2.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Rsamtools" version))
+ (sha256
+ (base32
+ "040pggkwglc6wy90qnc7xcdnaj0v3iqlykvvsl74241409qly554"))))
+ (properties
+ `((upstream-name . "Rsamtools")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-system-zlib
+ (lambda _
+ (substitute* "DESCRIPTION"
+ (("zlibbioc, ") ""))
+ (substitute* "NAMESPACE"
+ (("import\\(zlibbioc\\)") ""))
+ #t)))))
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-biostrings" ,r-biostrings)
+ ("r-bitops" ,r-bitops)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-rhtslib" ,r-rhtslib)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xvector" ,r-xvector)))
+ (home-page "https://bioconductor.org/packages/release/bioc/html/Rsamtools.html")
+ (synopsis "Interface to samtools, bcftools, and tabix")
+ (description
+ "This package provides an interface to the @code{samtools},
+@code{bcftools}, and @code{tabix} utilities for manipulating SAM (Sequence
+Alignment / Map), FASTA, binary variant call (BCF) and compressed indexed
+tab-delimited (tabix) files.")
+ (license license:expat)))
+
(define-public r-shortread
(package
(name "r-shortread")
@@ -2089,6 +2461,42 @@ annotation infrastructure.")
coding changes and predict coding outcomes.")
(license license:artistic2.0)))
+(define-public r-xvector
+ (package
+ (name "r-xvector")
+ (version "0.30.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "XVector" version))
+ (sha256
+ (base32
+ "1pqljikg4f6jb7wgm5537zwgq5b013nyz1agjrwfq2cljb0ym6lq"))))
+ (properties
+ `((upstream-name . "XVector")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-system-zlib
+ (lambda _
+ (substitute* "DESCRIPTION"
+ (("zlibbioc, ") ""))
+ (substitute* "NAMESPACE"
+ (("import\\(zlibbioc\\)") ""))
+ #t)))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-iranges" ,r-iranges)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "https://bioconductor.org/packages/XVector")
+ (synopsis "Representation and manpulation of external sequences")
+ (description
+ "This package provides memory efficient S4 classes for storing sequences
+\"externally\" (behind an R external pointer, or on disk).")
+ (license license:artistic2.0)))
+
(define-public r-geneplotter
(package
(name "r-geneplotter")
@@ -2297,14 +2705,14 @@ signal in the input, that lead to spurious peaks during peak calling.")
(define-public r-diffbind
(package
(name "r-diffbind")
- (version "3.0.14")
+ (version "3.0.15")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "DiffBind" version))
(sha256
(base32
- "1siabhjd0w7bb6v2gfhsm9j7c7c86z8m6lfsyl8p84h0zhjs2vrw"))))
+ "06f613s8d9z51njyf839g22gwybx9zs5n6xghwr5j1ad2n4m6qwi"))))
(properties `((upstream-name . "DiffBind")))
(build-system r-build-system)
(propagated-inputs
@@ -2511,14 +2919,14 @@ determining dependencies between variables, code improvement suggestions.")
(define-public r-chippeakanno
(package
(name "r-chippeakanno")
- (version "3.24.1")
+ (version "3.24.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "ChIPpeakAnno" version))
(sha256
(base32
- "0qdkwjv8s46d1kmgg2chijv7yzy9sv49kiks18w8x2z89prn15gj"))))
+ "0l417aygs89wf1j9fjpfjhahzskbpbgcrm8xpx3qm4s0307vfzkw"))))
(properties `((upstream-name . "ChIPpeakAnno")))
(build-system r-build-system)
(propagated-inputs
@@ -2527,6 +2935,7 @@ determining dependencies between variables, code improvement suggestions.")
("r-biomart" ,r-biomart)
("r-biostrings" ,r-biostrings)
("r-dbi" ,r-dbi)
+ ("r-dplyr" ,r-dplyr)
("r-ensembldb" ,r-ensembldb)
("r-genomeinfodb" ,r-genomeinfodb)
("r-genomicalignments" ,r-genomicalignments)
@@ -6500,14 +6909,14 @@ annotations.")
(define-public r-rsubread
(package
(name "r-rsubread")
- (version "2.4.2")
+ (version "2.4.3")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "Rsubread" version))
(sha256
(base32
- "1wczrw5jb69x45hd3rdqqs9vkysdqwlxn9h3kjzn57r4x5q7jrra"))))
+ "0c4akc89p5467n5rzq9bi7h0h15rbpqpvh7fw42qcj7g2vc41wba"))))
(properties `((upstream-name . "Rsubread")))
(build-system r-build-system)
(inputs `(("zlib" ,zlib)))
@@ -7966,14 +8375,14 @@ data.")
(define-public r-universalmotif
(package
(name "r-universalmotif")
- (version "1.8.3")
+ (version "1.8.4")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "universalmotif" version))
(sha256
(base32
- "1ys2kbayc1rzv8nzi60208yfslm4kzynndfg7vw2n0c30dvzycrc"))))
+ "0pmi5mp5v0srr482vlkfmkp28bywq969fvv9g5kjl5rxki963zmr"))))
(properties
`((upstream-name . "universalmotif")))
(build-system r-build-system)
@@ -10119,8 +10528,8 @@ experiments, and visualize de influence of the involved factors.")
by spectral counts, to discover differentially expressed proteins between two
biological conditions. Three tests are available: Poisson GLM regression,
quasi-likelihood GLM regression, and the negative binomial of the edgeR
-package.The three models admit blocking factors to control for nuissance
-variables.To assure a good level of reproducibility a post-test filter is
+package. The three models admit blocking factors to control for nuisance
+variables. To assure a good level of reproducibility a post-test filter is
available, where we may set the minimum effect size considered biologicaly
relevant, and the minimum expression of the most abundant condition.")
(license license:gpl2)))
@@ -10394,14 +10803,14 @@ family of feature/genome hypotheses.")
(define-public r-gviz
(package
(name "r-gviz")
- (version "1.34.0")
+ (version "1.34.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "Gviz" version))
(sha256
(base32
- "0v7bz46b91dnrr55ah42ljj1i2xs3090s4w0lw8098pag00p4vh2"))))
+ "0bmlfz9ri1gkwyl605a2hqi5b8jdpvynrxwghwmrsd657ip6c7n1"))))
(properties `((upstream-name . "Gviz")))
(build-system r-build-system)
(propagated-inputs
@@ -10622,6 +11031,44 @@ large-scale and fully automated analysis.")
the earlier snpMatrix package, allowing for uncertainty in genotypes.")
(license license:gpl3)))
+(define-public r-chromstar
+ (package
+ (name "r-chromstar")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "chromstaR" version))
+ (sha256
+ (base32
+ "0vgpb7g2cncdn82hia2yzzachyns2zbd7906662g990qjnp2xlm1"))))
+ (properties `((upstream-name . "chromstaR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bamsignals" ,r-bamsignals)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-chromstardata" ,r-chromstardata)
+ ("r-doparallel" ,r-doparallel)
+ ("r-foreach" ,r-foreach)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-iranges" ,r-iranges)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-s4vectors" ,r-s4vectors)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/ataudt/chromstaR")
+ (synopsis "Chromatin state analysis for ChIP-Seq data")
+ (description
+ "This package implements functions for combinatorial and differential
+analysis of ChIP-seq data. It includes uni- and multivariate peak-calling,
+export to genome browser viewable files, and functions for enrichment
+analyses.")
+ (license license:artistic2.0)))
+
(define-public r-sushi
(package
(name "r-sushi")