summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm116
1 files changed, 65 insertions, 51 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 341731d066..864c200707 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1254,7 +1254,9 @@ libblasr_gtest_dep = cpp.find_library('gtest_main', dirs : '~a')\n"
(list boost hdf5 htslib pbbam zlib))
(native-inputs
(list googletest pkg-config))
- (home-page "https://github.com/PacificBiosciences/blasr_libcpp")
+ (home-page
+ (string-append "https://web.archive.org/web/20201106122415/"
+ "https://github.com/PacificBiosciences/blasr_libcpp"))
(synopsis "Library for analyzing PacBio genomic sequences")
(description
"This package provides three libraries used by applications for analyzing
@@ -1296,7 +1298,8 @@ cpp.find_library('hdf5_cpp', dirs : '~a'), "
(list boost blasr-libcpp hdf5 pbbam zlib))
(native-inputs
(list pkg-config))
- (home-page "https://github.com/PacificBiosciences/blasr")
+ (home-page (string-append "https://web.archive.org/web/20210813124135/"
+ "https://github.com/PacificBiosciences/blasr"))
(synopsis "PacBio long read aligner")
(description
"Blasr is a genomic sequence aligner for processing PacBio long reads.")
@@ -1408,11 +1411,12 @@ Format (GFF) with Biopython integration.")
(license (license:non-copyleft "http://www.biopython.org/DIST/LICENSE"))))
(define-public python-bcbio-gff/biopython-1.73
- (package
- (inherit python-bcbio-gff)
- (propagated-inputs
- (modify-inputs (package-propagated-inputs python-bcbio-gff)
- (replace "python-biopython" python-biopython-1.73)))))
+ (hidden-package
+ (package
+ (inherit python-bcbio-gff)
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs python-bcbio-gff)
+ (replace "python-biopython" python-biopython-1.73))))))
;; Note: the name on PyPi is "biofluff".
(define-public python-biofluff
@@ -3347,7 +3351,9 @@ and more accurate. BWA-MEM also has better performance than BWA-backtrack for
(("inline int map") "int map"))))))))
(inputs
(list gdsl zlib perl))
- (home-page "http://bwa-pssm.binf.ku.dk/")
+ ;; https://bwa-pssm.binf.ku.dk is down, and all Web Archived copies are
+ ;; blank (they actually have "display:none" for some nefarious reason).
+ (home-page "https://github.com/pkerpedjiev/bwa-pssm")
(synopsis "Burrows-Wheeler transform-based probabilistic short read mapper")
(description
"BWA-PSSM is a probabilistic short genomic sequence read aligner based on
@@ -4759,17 +4765,15 @@ data and settings.")
(list boost cairo rmath-standalone))
(native-inputs
(list (texlive-updmap.cfg
- (list texlive-cm
- texlive-amsfonts
- texlive-doi
- texlive-fonts-ec
- texlive-latex-examplep
- texlive-hyperref
+ (list texlive-doi
+ texlive-examplep
+ texlive-forloop
+ texlive-listofitems
texlive-ms
- texlive-latex-natbib
- texlive-bibtex ;style files used by natbib
+ texlive-natbib
texlive-pgf ;tikz
- texlive-latex-verbatimbox))
+ texlive-readarray
+ texlive-verbatimbox))
imagemagick))
(home-page "https://dorina.mdc-berlin.de/public/rajewsky/discrover/")
(synopsis "Discover discriminative nucleotide sequence motifs")
@@ -7273,7 +7277,9 @@ program for nucleotide and protein sequences.")
"1hkw21rq1mwf7xp0rmbb2gqc0i6p11108m69i7mr7xcjl268pxnb"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags (list "CFLAGS=-O2 -g -fcommon")))
+ `(#:tests? ,(not (or (target-riscv64?) ;XXX: stuck on riscv64-linux
+ (%current-target-system)))
+ #:make-flags (list "CFLAGS=-O2 -g -fcommon")))
(inputs
;; XXX: TODO: Enable Lua and Guile bindings.
;; https://github.com/tjunier/newick_utils/issues/13
@@ -9826,6 +9832,14 @@ differently labelled data.")
(base32 "04kr1b28p5j7h48g32cldkg87xcmxnmd4kspygkfs7a4amihpi66"))))
(properties `((upstream-name . "Pando")))
(build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'loosen-requirements
+ (lambda _
+ (substitute* "DESCRIPTION"
+ ((" \\(==.*,") ",")))))))
(propagated-inputs
(list r-bayestestr
r-foreach
@@ -12088,16 +12102,15 @@ programs for inferring phylogenies (evolutionary trees).")
(list automake
autoconf
openmpi
- (texlive-updmap.cfg (list texlive-amsfonts
- texlive-caption
- texlive-cite
- texlive-fancyvrb
- texlive-fonts-ec
- texlive-graphics
- texlive-grfext
- texlive-hyperref
- texlive-latex-psfrag
- texlive-xcolor))))
+ (texlive-updmap.cfg
+ (list texlive-caption
+ texlive-cite
+ texlive-fancyvrb
+ texlive-infwarerr
+ texlive-kvoptions
+ texlive-pdftexcmds
+ texlive-psfrag
+ texlive-xcolor))))
(home-page "https://github.com/stephaneguindon/phyml")
(synopsis "Programs for working on SAM/BAM files")
(description
@@ -17051,32 +17064,33 @@ to an artifact/contaminant file.")
(delete-file-recursively "third-party")))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags '("OPENMP=t")
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'fix-zlib-include
- (lambda _
- (substitute* "src/binarySequences.c"
- (("../third-party/zlib-1.2.3/zlib.h") "zlib.h"))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (doc (string-append out "/share/doc/velvet")))
- (mkdir-p bin)
- (mkdir-p doc)
- (install-file "velveth" bin)
- (install-file "velvetg" bin)
- (install-file "Manual.pdf" doc)
- (install-file "Columbus_manual.pdf" doc)))))))
+ (list
+ #:make-flags #~(list "OPENMP=t")
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-zlib-include
+ (lambda _
+ (substitute* "src/binarySequences.c"
+ (("../third-party/zlib-1.2.3/zlib.h") "zlib.h"))))
+ (replace 'install
+ (lambda _
+ (let ((bin (string-append #$output "/bin"))
+ (doc (string-append #$output "/share/doc/velvet")))
+ (mkdir-p bin)
+ (mkdir-p doc)
+ (install-file "velveth" bin)
+ (install-file "velvetg" bin)
+ (install-file "Manual.pdf" doc)
+ (install-file "Columbus_manual.pdf" doc)))))))
(inputs
(list openmpi zlib))
(native-inputs
- `(("texlive" ,(texlive-updmap.cfg (list texlive-graphics
- texlive-fonts-ec
- texlive-hyperref)))))
+ (list (texlive-updmap.cfg
+ (list texlive-infwarerr
+ texlive-kvoptions
+ texlive-pdftexcmds))))
(home-page "https://www.ebi.ac.uk/~zerbino/velvet/")
(synopsis "Nucleic acid sequence assembler for very short reads")
(description