summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 36 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9cdc692d07..c3ba9634ba 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -51,7 +51,9 @@
#:use-module (gnu packages gawk)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gd)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages logging)
@@ -70,6 +72,7 @@
#:use-module (gnu packages ruby)
#:use-module (gnu packages statistics)
#:use-module (gnu packages tbb)
+ #:use-module (gnu packages tex)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
@@ -1603,6 +1606,33 @@ data and settings.")
(license (license:non-copyleft "file://src/COPYING"
"See src/COPYING in the distribution."))))
+(define-public discrover
+ (package
+ (name "discrover")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/maaskola/discrover/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rah9ja4m0rl5mldd6vag9rwrivw1zrqxssfq8qx64m7961fp68k"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; there are no tests
+ (inputs
+ `(("boost" ,boost)
+ ("cairo" ,cairo)))
+ (native-inputs
+ `(("texlive" ,texlive)
+ ("imagemagick" ,imagemagick)))
+ (home-page "http://dorina.mdc-berlin.de/public/rajewsky/discrover/")
+ (synopsis "Discover discriminative nucleotide sequence motifs")
+ (description "Discrover is a motif discovery method to find binding sites
+of nucleic acid binding proteins.")
+ (license license:gpl3+)))
+
(define-public eigensoft
(let ((revision "1")
(commit "b14d1e202e21e532536ff8004f0419cd5e259dc7"))
@@ -2108,6 +2138,8 @@ basic tasks but can change to using POSIX regular expressions, PCRE, hash
lookups or multi-pattern searching as required. By default fxtract looks in
the sequence of each record but can also be told to look in the header,
comment or quality sections.")
+ ;; 'util' requires SSE instructions.
+ (supported-systems '("x86_64-linux"))
(license license:expat))))
(define-public grit
@@ -4645,13 +4677,13 @@ CAGE.")
(define-public r-variantannotation
(package
(name "r-variantannotation")
- (version "1.18.1")
+ (version "1.18.6")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "VariantAnnotation" version))
(sha256
(base32
- "1jdpdnp7l81xfprba2ykfnj6i64fd84vxaax0wvrz6qahxvnjzyw"))))
+ "17q2b3wlv3250v6qm114srkarxykpd5rqmg4kzymmqsn1b8hynhv"))))
(properties
`((upstream-name . "VariantAnnotation")))
(inputs
@@ -5273,7 +5305,7 @@ genomic intervals. In addition, it can use BAM or BigWig files as input.")
(define-public r-genomationdata
(package
(name "r-genomationdata")
- (version "1.4.0")
+ (version "1.4.2")
(source (origin
(method url-fetch)
;; We cannot use bioconductor-uri here because this tarball is
@@ -5283,7 +5315,7 @@ genomic intervals. In addition, it can use BAM or BigWig files as input.")
"genomationData_" version ".tar.gz"))
(sha256
(base32
- "1xzq2j722d8lcn5bc3aq3yb34xwis2d0bpsf6jsq4xw1bg0bsy79"))))
+ "1zl7gg144fs7zfycsmq5492sm1bqy7l527xbc2zj04schd9wsan2"))))
(build-system r-build-system)
;; As this package provides little more than large data files, it doesn't
;; make sense to build substitutes.