summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm99
1 files changed, 94 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f90a0bf90c..32b795948b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -79,6 +79,7 @@
#:use-module (gnu packages golang)
#:use-module (gnu packages glib)
#:use-module (gnu packages graph)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages groff)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -4942,14 +4943,24 @@ files and writing bioinformatics applications.")
"1agfz6zqa8nc6cw47yh0s3y14gkpa9wqazwcj7mwwj3ffnw39p3j"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2)) ; requires Python 2.7
+ `(#:python ,python-2 ; requires Python 2.7
+ #:tests? #f ; test data are not included
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-weave
+ (lambda _
+ (substitute* "warpedlmm/util/linalg.py"
+ (("from scipy import linalg, weave")
+ "from scipy import linalg\nimport weave"))
+ #t)))))
(propagated-inputs
`(("python-scipy" ,python2-scipy)
("python-numpy" ,python2-numpy)
("python-matplotlib" ,python2-matplotlib)
("python-fastlmm" ,python2-fastlmm)
("python-pandas" ,python2-pandas)
- ("python-pysnptools" ,python2-pysnptools)))
+ ("python-pysnptools" ,python2-pysnptools)
+ ("python-weave" ,python2-weave)))
(native-inputs
`(("python-mock" ,python2-mock)
("python-nose" ,python2-nose)
@@ -11984,7 +11995,8 @@ dependency like SeqAn.")
;; Ensure that Eigen headers can be found
(setenv "CPLUS_INCLUDE_PATH"
(string-append (assoc-ref inputs "eigen")
- "/include/eigen3"))
+ "/include/eigen3:"
+ (or (getenv "CPLUS_INCLUDE_PATH") "")))
#t)))))
(inputs
`(("boost" ,boost)
@@ -12162,8 +12174,8 @@ The following file formats are supported:
(("lib/libdivsufsort.a") "/lib/libdivsufsort.so"))
;; Ensure that all headers can be found
- (setenv "CPATH"
- (string-append (getenv "CPATH")
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-append (or (getenv "CPLUS_INCLUDE_PATH") "")
":"
(assoc-ref inputs "eigen")
"/include/eigen3"))
@@ -13302,6 +13314,42 @@ cases include:
@end enumerate\n")
(license license:expat)))
+(define-public miniasm
+ (package
+ (name "miniasm")
+ (version "0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lh3/miniasm/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g89pa98dvh34idv7w1zv12bsbyr3a11c4qb1cdcz68gyda88s4v"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "miniasm" bin)
+ (install-file "minidot" bin)))))))
+ (home-page "https://github.com/lh3/miniasm")
+ (synopsis "Ultrafast de novo assembly for long noisy reads")
+ (description "Miniasm is a very fast OLC-based de novo assembler for noisy
+long reads. It takes all-vs-all read self-mappings (typically by minimap) as
+input and outputs an assembly graph in the GFA format. Different from
+mainstream assemblers, miniasm does not have a consensus step. It simply
+concatenates pieces of read sequences to generate the final unitig sequences.
+Thus the per-base error rate is similar to the raw input reads.")
+ (license license:expat)))
+
(define-public r-circus
(package
(name "r-circus")
@@ -15807,3 +15855,44 @@ biological processes. SBML is useful for models of metabolism, cell
signaling, and more. It continues to be evolved and expanded by an
international community.")
(license license:lgpl2.1+)))
+
+(define-public grocsvs
+ ;; The last release is out of date and new features have been added.
+ (let ((commit "ecd956a65093a0b2c41849050e4512d46fecea5d")
+ (revision "1"))
+ (package
+ (name "grocsvs")
+ (version (git-version "0.2.6.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grocsvs/grocsvs")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14505725gr7qxc17cxxf0k6lzcwmgi64pija4mwf29aw70qn35cc"))
+ (patches (search-patches "grocsvs-dont-use-admiral.patch"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; No test suite.
+ #:python ,python-2)) ; Only python-2 supported.
+ (inputs
+ `(("python2-h5py" ,python2-h5py)
+ ("python2-ipython-cluster-helper" ,python2-ipython-cluster-helper)
+ ("python2-networkx" ,python2-networkx)
+ ("python2-psutil" ,python2-psutil)
+ ("python2-pandas" ,python2-pandas)
+ ("python2-pybedtools" ,python2-pybedtools)
+ ("python2-pyfaidx" ,python2-pyfaidx)
+ ("python2-pygraphviz" ,python2-pygraphviz)
+ ("python2-pysam" ,python2-pysam)
+ ("python2-scipy" ,python2-scipy)))
+ (home-page "https://github.com/grocsvs/grocsvs")
+ (synopsis "Genome-wide reconstruction of complex structural variants")
+ (description
+ "@dfn{Genome-wide Reconstruction of Complex Structural Variants}
+(GROC-SVs) is a software pipeline for identifying large-scale structural
+variants, performing sequence assembly at the breakpoints, and reconstructing
+the complex structural variants using the long-fragment information from the
+10x Genomics platform.")
+ (license license:expat))))