summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm35
1 files changed, 6 insertions, 29 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a552686328..481a2a3bcb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -680,15 +680,10 @@ bioinformatics programs; a standard sequence class and tools for performing
common operations on them; code to perform data classification; code for
dealing with alignments; code making it easy to split up parallelizable tasks
into separate processes; and more.")
- (license (license:non-copyleft "http://www.biopython.org/DIST/LICENSE"))
- (properties `((python2-variant . ,(delay python2-biopython))))))
+ (license (license:non-copyleft "http://www.biopython.org/DIST/LICENSE"))))
(define-public python2-biopython
- (let ((base (package-with-python2 (strip-python2-variant python-biopython))))
- (package
- (inherit base)
- (native-inputs `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-biopython))
;; An outdated version of biopython is required for seqmagick, see
;; https://github.com/fhcrc/seqmagick/issues/59
@@ -1427,7 +1422,6 @@ also includes an interface for tabix.")
(sha256
(base32
"1q8wnj2kga9nz1lwc4w7qv52smfm536hp6mc8w6s53lhyj0mpi22"))))
- (properties `((python2-variant . ,(delay python2-twobitreader))))
(build-system python-build-system)
(arguments
'(;; Tests are not distributed in the PyPi release.
@@ -1444,11 +1438,7 @@ UCSC genome browser.")
(license license:artistic2.0)))
(define-public python2-twobitreader
- (let ((base (package-with-python2 (strip-python2-variant python-twobitreader))))
- (package
- (inherit base)
- (native-inputs `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-twobitreader))
(define-public python-plastid
(package
@@ -1460,7 +1450,6 @@ UCSC genome browser.")
(sha256
(base32
"1sqkz5d3b9kf688mp7k771c87ins42j7j0whmkb49cb3fsg8s8lj"))))
- (properties `((python2-variant . ,(delay python2-plastid))))
(build-system python-build-system)
(arguments
;; Some test files are not included.
@@ -1485,12 +1474,7 @@ high-throughput sequencing data – with an emphasis on simplicity.")
(license license:bsd-3)))
(define-public python2-plastid
- (let ((base (package-with-python2 (strip-python2-variant python-plastid))))
- (package
- (inherit base)
- ;; setuptools is required at runtime
- (propagated-inputs `(("python2-setuptools" ,python2-setuptools)
- ,@(package-propagated-inputs base))))))
+ (package-with-python2 python-plastid))
(define-public cd-hit
(package
@@ -1939,10 +1923,7 @@ accessing bigWig files.")
(license license:expat)))
(define-public python2-pybigwig
- (let ((pybigwig (package-with-python2 python-pybigwig)))
- (package (inherit pybigwig)
- (native-inputs
- `(("python-setuptools" ,python2-setuptools))))))
+ (package-with-python2 python-pybigwig))
(define-public python-dendropy
(package
@@ -4568,11 +4549,7 @@ sequence itself can be retrieved from these databases.")
(license license:bsd-3)))
(define-public python2-screed
- (let ((base (package-with-python2 (strip-python2-variant python-screed))))
- (package
- (inherit base)
- (native-inputs `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-screed))
(define-public sra-tools
(package