summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm113
1 files changed, 67 insertions, 46 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 432589391b..3628d6231a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -295,9 +295,10 @@ BAM files.")
(base32
"1vgw2mwngq20c530zim52zvgmw1lci8rzl33pvh44xqk3xlzvjsa"))
(modules '((guix build utils)))
- (snippet
- ;; Delete bundled htslib.
- '(delete-file-recursively "htslib-1.8"))))
+ (snippet '(begin
+ ;; Delete bundled htslib.
+ (delete-file-recursively "htslib-1.8")
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -1194,10 +1195,12 @@ errors at the end of reads.")
"0hwa5r9qbglppb7sz5z79rlmmddr3n51n468jb3wh8rwjgn3yr90"))
(modules '((guix build utils)))
(snippet
- '(substitute* "Makefile"
- ;; replace BUILD_HOST and BUILD_TIME for deterministic build
- (("-DBUILD_HOST=.*") "-DBUILD_HOST=\"\\\"guix\\\"\"")
- (("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))))
+ '(begin
+ (substitute* "Makefile"
+ ;; replace BUILD_HOST and BUILD_TIME for deterministic build
+ (("-DBUILD_HOST=.*") "-DBUILD_HOST=\"\\\"guix\\\"\"")
+ (("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\""))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("perl" ,perl)
@@ -1391,10 +1394,12 @@ well as many of the command line options.")
"15z2w3bvnc0n4qmb9bd6d8ylc2h2nj883x2w9iixf4x3vki9b22i"))
(modules '((guix build utils)))
(snippet
- '(substitute* "setup.py"
- ;; remove dependency on outdated "distribute" module
- (("^from distribute_setup import use_setuptools") "")
- (("^use_setuptools\\(\\)") "")))))
+ '(begin
+ (substitute* "setup.py"
+ ;; remove dependency on outdated "distribute" module
+ (("^from distribute_setup import use_setuptools") "")
+ (("^use_setuptools\\(\\)") ""))
+ #t))))
(build-system python-build-system)
(arguments
`(#:tests? #f ;tests fail because test data are not included
@@ -1426,9 +1431,11 @@ multiple sequence alignments.")
(base32
"0dzap2axin9cbbl0d825w294bpn00zagfm1sigamm4v2pm5bj9lp"))
(modules '((guix build utils)))
- (snippet
- ;; Drop bundled htslib. TODO: Also remove samtools and bcftools.
- '(delete-file-recursively "htslib"))))
+ (snippet '(begin
+ ;; Drop bundled htslib. TODO: Also remove samtools
+ ;; and bcftools.
+ (delete-file-recursively "htslib")
+ #t))))
(build-system python-build-system)
(arguments
`(#:modules ((ice-9 ftw)
@@ -1800,9 +1807,10 @@ time.")
;; for download from Sourceforge, but it has not been merged.
(patches (search-patches "crossmap-allow-system-pysam.patch"))
(modules '((guix build utils)))
- ;; remove bundled copy of pysam
- (snippet
- '(delete-file-recursively "lib/pysam"))))
+ (snippet '(begin
+ ;; remove bundled copy of pysam
+ (delete-file-recursively "lib/pysam")
+ #t))))
(build-system python-build-system)
(arguments
`(#:python ,python-2
@@ -1911,7 +1919,8 @@ files.")
(snippet
'(begin
;; Delete bundled libBigWig sources
- (delete-file-recursively "libBigWig")))))
+ (delete-file-recursively "libBigWig")
+ #t))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -3145,6 +3154,8 @@ manipulating HTS data.")
#:jdk ,icedtea-8
#:phases
(modify-phases %standard-phases
+ ;; FIXME: this phase fails with "duplicate entry: htsjdk/samtools/AbstractBAMFileIndex$1.class"
+ (delete 'generate-jar-indices)
(add-after 'unpack 'use-our-htsjdk
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "build.xml"
@@ -3202,6 +3213,8 @@ VCF.")
(sxml xpath))
#:phases
(modify-phases %standard-phases
+ ;; FIXME: this phase fails with "duplicate entry: htsjdk/samtools/AbstractBAMFileIndex$1.class"
+ (delete 'generate-jar-indices)
(add-after 'unpack 'remove-useless-build.xml
(lambda _ (delete-file "build.xml") #t))
;; This is necessary to ensure that htsjdk is found when using
@@ -3292,6 +3305,8 @@ VCF.")
(list "-Dsamjdk.intel_deflater_so_path=lib/jni/libIntelDeflater.so")
#:phases
(modify-phases %standard-phases
+ ;; FIXME: This phase fails.
+ (delete 'generate-jar-indices)
;; Do not use bundled ant bzip2.
(add-after 'unpack 'use-ant-bzip
(lambda* (#:key inputs #:allow-other-keys)
@@ -3870,9 +3885,11 @@ sequences).")
"00fx14vpmgsijwxd1xql3if934l82v8ckqgjjyyhnr36qb9qrskv"))
(modules '((guix build utils)))
(snippet
- ;; Delete bundled kseq.
- ;; TODO: Also delete bundled murmurhash and open bloom filter.
- '(delete-file "src/mash/kseq.h"))))
+ '(begin
+ ;; Delete bundled kseq.
+ ;; TODO: Also delete bundled murmurhash and open bloom filter.
+ (delete-file "src/mash/kseq.h")
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No tests.
@@ -4052,18 +4069,19 @@ assembled metagenomic sequence.")
(base32
"1z3x0vd8ma7pdrnywj7i3kgwl89sdkwrrn62zl7r5calqaq2hyip"))
(modules '((guix build utils)))
- (snippet
- '(substitute* "setup.py"
- ;; Use setuptools, or else the executables are not
- ;; installed.
- (("distutils.core") "setuptools")
- ;; use "gcc" instead of "cc" for compilation
- (("^defines")
- "cc.set_executables(
+ (snippet '(begin
+ (substitute* "setup.py"
+ ;; Use setuptools, or else the executables are not
+ ;; installed.
+ (("distutils.core") "setuptools")
+ ;; use "gcc" instead of "cc" for compilation
+ (("^defines")
+ "cc.set_executables(
compiler='gcc',
compiler_so='gcc',
linker_exe='gcc',
-linker_so='gcc -shared'); defines")))))
+linker_so='gcc -shared'); defines"))
+ #t))))
(build-system python-build-system)
(arguments
`(#:python ,python-2 ; only Python 2 is supported
@@ -4864,7 +4882,8 @@ BAM and Wiggle files in both transcript-coordinate and genomic-coordinate.")
(("^from distribute_setup import use_setuptools") "")
(("^use_setuptools\\(\\)") "")
;; do not use bundled copy of pysam
- (("^have_pysam = False") "have_pysam = True"))))))
+ (("^have_pysam = False") "have_pysam = True"))
+ #t))))
(build-system python-build-system)
(arguments `(#:python ,python-2))
(inputs
@@ -4915,9 +4934,9 @@ distribution, coverage uniformity, strand specificity, etc.")
"Data2DB"
"PCL2Bin")))
(modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (replace 'bootstrap
(lambda _
- (zero? (system* "bash" "gen_auto"))))
+ (invoke "bash" "gen_auto")))
(add-after 'build 'build-additional-tools
(lambda* (#:key make-flags #:allow-other-keys)
(every (lambda (dir)
@@ -5420,9 +5439,10 @@ structures, classes for genomic regions, mapped sequencing reads, etc.")
(sha256
(base32 "08r684l50pnxjpvmhzjgqq56yv9rfw90k8vx0nsrnrzk8mf9hsdq"))
(modules '((guix build utils)))
- (snippet
- ;; Remove bundled samtools.
- '(delete-file-recursively "samtools"))))
+ (snippet '(begin
+ ;; Remove bundled samtools.
+ (delete-file-recursively "samtools")
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;no "check" target
@@ -5627,10 +5647,11 @@ writing files into the .sra format.")
(out (assoc-ref %outputs "out"))
(doc (assoc-ref %outputs "doc")))
(setenv "PATH" (string-append tar "/bin:" bzip "/bin"))
- (system* "tar" "xvf" (assoc-ref %build-inputs "source"))
+ (invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
(chdir (string-append "seqan-library-" ,version))
(copy-recursively "include" (string-append out "/include"))
- (copy-recursively "share" (string-append doc "/share"))))))
+ (copy-recursively "share" (string-append doc "/share"))
+ #t))))
(native-inputs
`(("source" ,source)
("tar" ,tar)
@@ -11034,11 +11055,6 @@ droplet sequencing. It has been particularly tailored for Drop-seq.")
(sha256
(base32
"0g38g8s3npr0gjm9fahlbhiskyfws9l5i0x1ml3rakzj7az5l9c9"))))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _ (invoke "autoreconf" "-vif"))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -11952,7 +11968,8 @@ bytes of memory space, where n is the length of the string.")
(snippet
'(begin (delete-file-recursively "include/spdlog")
(for-each delete-file '("include/xxhash.h"
- "src/xxhash.c"))))))
+ "src/xxhash.c"))
+ #t))))
("libdivsufsort" ,libdivsufsort)
("libgff" ,libgff)
("tbb" ,tbb)
@@ -12677,7 +12694,8 @@ contains
(snippet
'(begin
(for-each delete-file (find-files "jar/lib" "\\.jar$"))
- (delete-file-recursively "3rdParty")))))
+ (delete-file-recursively "3rdParty")
+ #t))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; test data are not included
@@ -12696,6 +12714,9 @@ contains
(guix build ant-build-system))
#:phases
(modify-phases %standard-phases
+ ;; FIXME: fails with "java.io.FileNotFoundException:
+ ;; /gnu/store/q76y0ximcziplgfpbn26kbw4h3s14f33-dropseq-tools-1.13/share/java/lib/biojava-alignment.jar"
+ (delete 'generate-jar-indices)
;; All dependencies must be linked to "lib", because that's where
;; they will be searched for when the Class-Path property of the
;; manifest is computed.
@@ -13053,7 +13074,7 @@ methylation and segmentation.")
("perl" ,perl)
("dropseq-tools" ,dropseq-tools)
("fastqc" ,fastqc)
- ("java-picard" ,java-picard)
+ ("java-picard" ,java-picard-2.10.3) ; same as for dropseq
("java" ,icedtea-8)
("python-wrapper" ,python-wrapper)
("python-pyyaml" ,python-pyyaml)