summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm112
1 files changed, 109 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7dbebcf3da..f75254ed9f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2110,6 +2110,29 @@ matplotlib Axes objects, making them easy to style and incorporate into
multi-panel figures.")
(license license:expat)))
+(define-public python-parabam
+ (package
+ (name "python-parabam")
+ (version "3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "parabam" version))
+ (sha256
+ (base32 "1cy9q3gzdawi1kilycpd7waymjmrwsg8czwycfp13g301ir9xyp3"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "setup.py"
+ (("'argparse',") "")))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy python-pysam))
+ (home-page "https://github.com/cancerit/parabam")
+ (synopsis "Parallel BAM File Analysis")
+ (description "Parabam is a tool for processing sequencing files in
+parallel. It uses Python's native multiprocessing framework to apply a user
+defined rule on an input file.")
+ (license license:gpl3)))
+
(define-public python-peaks2utr
(package
(name "python-peaks2utr")
@@ -2424,6 +2447,30 @@ operations:
@end itemize")
(license license:asl2.0)))
+(define-public python-telomerecat
+ (package
+ (name "python-telomerecat")
+ (version "4.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "telomerecat" version))
+ (sha256
+ (base32 "16mfdqmp0j6g3h26h59334w9lqb4qihqrlzwvgznj0fiqs1rkxn2"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-click python-numpy python-pandas
+ python-parabam python-pysam))
+ (home-page "https://github.com/cancerit/telomerecat")
+ (synopsis "Telomere computational analysis tool")
+ (description "Telomerecat is a tool for estimating the average telomere
+length (TL) for a paired end, whole genome sequencing (WGS) sample.
+
+Telomerecat is adaptable, accurate and fast. The algorithm accounts for
+sequencing amplification artifacts, anneouploidy (common in cancer samples)
+and noise generated by WGS. For a high coverage WGS BAM file of around 100GB
+telomerecat can produce an estimate in ~1 hour.")
+ (license license:gpl3)))
+
(define-public python-bioframe
(package
(name "python-bioframe")
@@ -11124,6 +11171,65 @@ single-cell data.")
"This package is designed to streamline scATAC analyses in R.")
(license license:gpl2+))))
+(define-public r-azimuth
+ (let ((commit "243ee5db80fcbffa3452c944254a325a3da2ef9e")
+ (revision "1"))
+ (package
+ (name "r-azimuth")
+ (version (git-version "0.5.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/satijalab/azimuth")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vs4813kf2cv2j1z800ihwk62bw4dgmwgkd47rln58581chv39zm"))))
+ (properties `((upstream-name . "Azimuth")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bsgenome-hsapiens-ucsc-hg38
+ r-dt
+ r-ensdb-hsapiens-v86
+ r-future
+ r-ggplot2
+ r-glmgampoi
+ r-googlesheets4
+ r-hdf5r
+ r-htmltools
+ r-httr
+ r-jaspar2020
+ r-jsonlite
+ r-matrix
+ r-patchwork
+ r-plotly
+ r-presto
+ r-rcpp
+ r-rlang
+ r-scales
+ r-seurat
+ r-seuratdata
+ r-seuratdisk
+ r-seuratobject
+ r-shiny
+ r-shinybs
+ r-shinydashboard
+ r-shinyjs
+ r-signac
+ r-stringr
+ r-tfbstools
+ r-withr))
+ (home-page "https://github.com/satijalab/azimuth")
+ (synopsis
+ "Shiny app showcasing a single-cell data query-reference mapping algorithm")
+ (description "Azimuth utilizes an annotated reference dataset. It
+automates the processing, analysis, and interpretation. This applies
+specifically to new single-cell RNA-seq or ATAC-seq experiments. Azimuth
+leverages a reference-based mapping pipeline that inputs acounts matrix and
+performs normalization, visualization, cell annotation, and differential
+expression.")
+ (license license:gpl3))))
+
(define-public r-icellnet
;; v1.0 tagged in 2020, last commit contains many fixes.
;; DESCRIPTION says Version: 0.0.0.9000.
@@ -20309,11 +20415,11 @@ translates between different variant encodings.")
(license license:asl2.0))))
(define-public r-signac
- (let ((commit "af4142724b72574d957f7fe3d422ed5828ec3ad0")
+ (let ((commit "8ecdde291676102bb3b503f48926c993354b5471")
(revision "1"))
(package
(name "r-signac")
- (version (git-version "1.9.0" revision commit))
+ (version (git-version "1.12.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -20322,7 +20428,7 @@ translates between different variant encodings.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ps0lp1dcy20r6lakil6ih81m04r0s6fnirvfjf01sfs0gsyddww"))))
+ "0idkcqb1i13m164nxbdwgs3vflw0cxzm2ir84aw0i811vx9lqz8c"))))
(properties `((upstream-name . "Signac")))
(build-system r-build-system)
(inputs (list zlib))