summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index cf70a29775..d1b359b2cb 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -43,7 +43,7 @@
(define-public boost
(package
(name "boost")
- (version "1.66.0")
+ (version "1.68.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -52,7 +52,7 @@
".tar.bz2"))
(sha256
(base32
- "1aaw48cmimsskzgiclwn0iifp62a5iw9cbqrhfari876af1828ap"))
+ "1dyqsr9yb01y0nnjdq9b8q5s2kvhxbayk34832k5cpzn7jy30qbz"))
(patches (search-patches "boost-fix-icu-build.patch"))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)
@@ -78,7 +78,6 @@
(out (assoc-ref outputs "out")))
(substitute* '("libs/config/configure"
"libs/spirit/classic/phoenix/test/runtest.sh"
- "tools/build/doc/bjam.qbk"
"tools/build/src/engine/execunix.c"
"tools/build/src/engine/Jambase"
"tools/build/src/engine/jambase.c")
@@ -100,7 +99,18 @@
make-flags)))
(replace 'install
(lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "./b2" "install" make-flags))))))
+ (apply invoke "./b2" "install" make-flags)))
+ (add-after 'install 'provide-libboost_python
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; Boost can build support for both Python 2 and Python 3 since
+ ;; version 1.67.0, and suffixes each library with the Python
+ ;; version. Many consumers only check for libboost_python
+ ;; however, so we provide it here as suggested in
+ ;; <https://github.com/boostorg/python/issues/203>.
+ (with-directory-excursion (string-append out "/lib")
+ (symlink "libboost_python27.so" "libboost_python.so"))
+ #t))))))
(home-page "https://www.boost.org")
(synopsis "Peer-reviewed portable C++ source libraries")