summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 0715802bc5..b22df415e8 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -716,22 +716,26 @@ tree binary files. These are board description files used by Linux and BSD.")
;; https://lists.denx.de/pipermail/u-boot/2021-October/462728.html
(search-patch "u-boot-allow-disabling-openssl.patch"))
+(define %u-boot-build-without-libcrypto-patch
+ ;; Upstream commit to fix Amlogic builds in u-boot 2024.01.
+ (search-patch "u-boot-build-without-libcrypto.patch"))
+
(define u-boot
(package
(name "u-boot")
- (version "2023.10")
+ (version "2024.01")
(source (origin
(patches
(list %u-boot-rockchip-inno-usb-patch
- %u-boot-allow-disabling-openssl-patch
- (search-patch "u-boot-patman-change-id.patch")))
+ %u-boot-build-without-libcrypto-patch
+ %u-boot-allow-disabling-openssl-patch))
(method url-fetch)
(uri (string-append
"https://ftp.denx.de/pub/u-boot/"
"u-boot-" version ".tar.bz2"))
(sha256
(base32
- "0039rravvjq9yi41645fynycw4c869px024xfc0n212f05pnq3p0"))))
+ "1czmpszalc6b8cj9j7q6cxcy19lnijv3916w3dag6yr3xpqi35mr"))))
(build-system gnu-build-system)
(native-inputs
(list bison