summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm26
1 files changed, 23 insertions, 3 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index ac5f64f48f..9af0ea7b09 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -94,9 +95,28 @@ caching facility provided by the library.")
for CD-ROM and CD image file access. It allows the developer to add CD
access to an application without having to worry about the OS- and
device-dependent properties of CD-ROM or the specific details of CD image
-formats. It includes pycdio, a Python interface to libcdio, and
-libcdio-paranoia, a library providing jitter-free and error-free audio
-extraction from CDs.")
+formats.")
+ (license gpl3+)))
+
+(define-public libcdio-paranoia
+ (package
+ (name "libcdio-paranoia")
+ (version "10.2+0.93+1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/libcdio/libcdio-paranoia-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "14x4b4jk5b0zvcalrg02y4jmbkmmlb07qfmk5hph9k18b8frn7gc"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (propagated-inputs `(("libcdio" ,libcdio)))
+ (home-page "http://www.gnu.org/software/libcdio/")
+ (synopsis "Jitter- and error-tolerant CD audio extraction")
+ (description
+ "libcdio-paranoia is an implementation of CD paranoia libraries based on
+libcdio.")
(license gpl3+)))
(define-public xorriso