summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm60
1 files changed, 55 insertions, 5 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 38190340f1..598b584cb3 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 John Darrington <jmd@gnu.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 ng0 <ng0@n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -160,9 +161,7 @@ libcdio.")
(inputs
`(("acl" ,acl)
("readline" ,readline)
- ("bzip2" ,bzip2)
- ("zlib" ,zlib)
- ("libcdio" ,libcdio)))
+ ("zlib" ,zlib)))
(home-page "https://www.gnu.org/software/xorriso/")
(synopsis "Create, manipulate, burn ISO-9660 file systems")
(description
@@ -350,7 +349,7 @@ capacity is user-selectable.")
(define-public dvdstyler
(package
(name "dvdstyler")
- (version "3.0.3")
+ (version "3.0.4")
(source
(origin
(method url-fetch)
@@ -358,7 +357,7 @@ capacity is user-selectable.")
version "/DVDStyler-" version ".tar.bz2"))
(sha256
(base32
- "1j432kszmwmsd3nz398h5514dbm5vsrn4rr3iil72ckjj1h3i00q"))))
+ "0lwc0hn94m9r8fi07sjqz3fr618l6lnw3zsakxw7nlgnxbjsk7pi"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list (string-append "XMLTO="
@@ -694,3 +693,54 @@ distributed with CD images and are used to describe how tracks are
laid out on the image.")
(home-page "https://www.gnu.org/software/ccd2cue/")
(license gpl3+)))
+
+(define-public libburn
+ (package
+ (name "libburn")
+ (version "1.4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://files.libburnia-project.org/releases/"
+ "libburn-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wbh49s3az3sfpai09z1zdgynq7wnwrk31v5589033274nmzldlx"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://dev.lovelyhq.com/libburnia/libburn")
+ (synopsis "Library for reading and writing optical discs")
+ (description
+ "Libburn is a library for reading and writing optical discs.
+Supported media are: CD-R, CD-RW, DVD-RAM, DVD+RW, DVD+R, DVD+R/DL,
+DVD-RW, DVD-R, DVD-R/DL, BD-R, and BD-RE.")
+ (license gpl2)))
+
+(define-public libisofs
+ (package
+ (name "libisofs")
+ (version "1.4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://files.libburnia-project.org/releases/"
+ "libisofs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02m5g6lbmmkh2xc5xzq5zaf3ma6v31gls66aj886b3cq9qw0paql"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("zlib" ,zlib)
+ ("acl" ,acl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://dev.lovelyhq.com/libburnia/libisofs")
+ (synopsis "Library to create ISO 9660 images")
+ (description
+ "Libisofs creates ISO 9660 (also known as ECMA-119) filesystem images
+which can either be written to POSIX file objects or handed over to
+libburn for being written directly to optical media.
+It can read metadata of ISO 9660 filesystems, manipulate them, and use them
+to produce new complete filesystem images or add-on images to be appended
+to the read filesystem image.
+Supported extensions to ISO 9660 are Rock Ridge, Joliet, AAIP, zisofs.")
+ (license gpl2+)))