summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index a222652295..d94636ba4c 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -293,17 +293,26 @@ images.")
`(#:tests? #f ; No tests.
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-glibc-compatability
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; We use sed --in-place because substitute* cannot handle the
+ ;; character encoding used by growisofs.c.
+ (invoke "sed" "-i" "-e"
+ (string-append
+ "s,<sys/stat.h>,"
+ "<sys/stat.h>\\\n#include <sys/sysmacros.h>,")
+ "growisofs.c")))
(replace 'configure
(lambda _ (setenv "prefix" (assoc-ref %outputs "out")) #t))
(add-before 'build 'embed-mkisofs
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda* (#:key inputs #:allow-other-keys)
;; We use sed --in-place because substitute* cannot handle the
;; character encoding used by growisofs.c.
- (zero? (system* "sed" "-i" "-e"
- (string-append
- "s,\"mkisofs\","
- "\"" (which "mkisofs") "\",")
- "growisofs.c")))))))
+ (invoke "sed" "-i" "-e"
+ (string-append
+ "s,\"mkisofs\","
+ "\"" (which "mkisofs") "\",")
+ "growisofs.c"))))))
(home-page "http://fy.chalmers.se/~appro/linux/DVD+RW/")
(synopsis "DVD and Blu-ray Disc burning tools")
(description "dvd+rw-tools, mostly known for its command