summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 80e0b94d01..93582a4b5f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1416,6 +1417,30 @@ distributed testing in both @code{load} and @code{each} modes. It also
supports coverage of subprocesses.")
(license license:expat)))
+(define-public python-pytest-dotenv
+ (package
+ (name "python-pytest-dotenv")
+ (version "0.5.2")
+ (source
+ (origin
+ ;; No tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/quiqua/pytest-dotenv")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bdxwaak5clhsd63b9q65nf2amqqv5hfn7dskfakyldxsqnnh0y6"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-dotenv))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/quiqua/pytest-dotenv")
+ (synopsis "Automatically detect and load a .env file before running tests")
+ (description
+ "This Pytest plugin automatically detects and loads environment variables
+from a .env file before running tests.")
+ (license license:expat)))
+
(define-public python-pytest-httpserver
(package
(name "python-pytest-httpserver")