summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm54
1 files changed, 16 insertions, 38 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1cf953ca2a..d7920ee27b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1315,44 +1315,27 @@ same arguments.")
(define-public python-pytest-xdist
(package
(name "python-pytest-xdist")
- (version "2.1.0")
+ (version "2.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-xdist" version))
(sha256
(base32
- "0wh6pn66nncfs6ay0n863bgyriwsgppn8flx5l7551j1lbqkinc2"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove pre-compiled .pyc files from source.
- (for-each delete-file-recursively
- (find-files "." "__pycache__" #:directories? #t))
- (for-each delete-file (find-files "." "\\.pyc$"))
- #t))))
+ "1psf5dqxvc38qzxvc305mkg5xpdmdkbkkfiyqlmdnkgh7z5dx025"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f ; Lots of tests fail.
- #:phases
+ '(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-setup-py
- (lambda _
- ;; Relax pytest requirement.
- (substitute* "setup.py"
- (("pytest>=6\\.0\\.0") "pytest"))))
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv"
"-n" (number->string (parallel-job-count)))))))))
- (native-inputs
- (list python-setuptools-scm))
- (propagated-inputs
- (list python-execnet python-pytest python-py python-pytest-forked))
- (home-page
- "https://github.com/pytest-dev/pytest-xdist")
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-execnet python-pytest python-py
+ python-pytest-forked))
+ (home-page "https://github.com/pytest-dev/pytest-xdist")
(synopsis
"Plugin for py.test with distributed testing and loop-on-failing modes")
(description
@@ -1411,7 +1394,7 @@ timeout has been exceeded.")
(define-public python-pytest-forked
(package
(name "python-pytest-forked")
- (version "1.3.0")
+ (version "1.4.0")
(source
(origin
(method git-fetch) ;for tests
@@ -1421,29 +1404,24 @@ timeout has been exceeded.")
(file-name (git-file-name name version))
(sha256
(base32
- "1aip4kx50ynvykl7kq2mlbsi82vx701dvb8mm64lhp69bbv105rc"))))
+ "0j9bbjny7h3b4fig6l26f26c697r67mm62fzdd9m9rqyy2bmnqjs"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'disable-setuptools-scm
+ (add-before 'build 'pretend-version
(lambda _
- (substitute* "setup.py"
- (("use_scm_version=True")
- (format #f "version=~s" ,version))
- (("setup_requires=\\['setuptools_scm'\\],.*")
- ""))))
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" ,version)))
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv")))))))
(native-inputs
;; XXX: The bootstrap variant of Pytest is used to ensure the
;; 'hypothesis' plugin is not in the environment (due to
;; <http://issues.guix.gnu.org/25235>), which would cause the test suite
;; to fail (see: https://github.com/pytest-dev/pytest-forked/issues/54).
- `(("python-pytest" ,python-pytest-bootstrap)))
+ (list python-pytest-bootstrap python-setuptools-scm))
(home-page "https://github.com/pytest-dev/pytest-forked")
(synopsis "Pytest plugin to run tests in isolated forked subprocesses")
(description "This package provides a Pytest plugin which enables running
@@ -2857,7 +2835,7 @@ portable to just about any platform.")
(define-public libfaketime
(package
(name "libfaketime")
- (version "0.9.9")
+ (version "0.9.10")
(home-page "https://github.com/wolfcw/libfaketime")
(source (origin
(method git-fetch)
@@ -2866,7 +2844,7 @@ portable to just about any platform.")
(commit (string-append "v" version))))
(sha256
(base32
- "1gi1xciqga5hl2xlk7rc3j8wy47ag97pi7ngmdl6ny1d11b2wn1z"))
+ "112l7x2gv4f47hpffpb8djfwvgrs8w5h9s266h1fshi1c916x10d"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments