summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm68
1 files changed, 59 insertions, 9 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index cf9b85d592..1300f9e1a6 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -81,7 +82,8 @@
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
- #:use-module (guix build-system trivial))
+ #:use-module (guix build-system trivial)
+ #:use-module (srfi srfi-1))
(define-public pedansee
(package
@@ -264,14 +266,14 @@ with a flexible variety of user interfaces.")
(define-public cppunit
(package
(name "cppunit")
- (version "1.14.0")
+ (version "1.15.1")
(source (origin
(method url-fetch)
(uri (string-append "http://dev-www.libreoffice.org/src/"
name "-" version ".tar.gz"))
(sha256
(base32
- "1027cyfx5gsjkdkaf6c2wnjh68882grw8n672018cj3vs9lrhmix"))))
+ "19qpqzy66bq76wcyadmi3zahk5v1ll2kig1nvg96zx9padkcdic9"))))
;; Explicitly link with libdl. This is expected to be done by packages
;; relying on cppunit for their tests. However, not all of them do.
;; If we added the linker flag to such packages, we would pollute all
@@ -440,7 +442,7 @@ format.")
(define-public cppcheck
(package
(name "cppcheck")
- (version "1.90")
+ (version "2.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -448,7 +450,7 @@ format.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0h7ir2x0k005fm586dxmaphgv5cyz25k3k4sh02p7zb78gzx398h"))))
+ (base32 "03ic5mig3ryzkf85r95ryagf84s7y5nd6sqr915l3zj30apnifvz"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DBUILD_TESTS=ON")))
@@ -509,7 +511,7 @@ and it supports a very flexible form of test discovery.")
(define-public doctest
(package
(name "doctest")
- (version "2.4.1")
+ (version "2.4.4")
(home-page "https://github.com/onqtam/doctest")
(source (origin
(method git-fetch)
@@ -517,7 +519,7 @@ and it supports a very flexible form of test discovery.")
(file-name (git-file-name name version))
(sha256
(base32
- "17g7n6rjs90i0b231x5s934qnr8m80ga2yg1z344bnsdiqcjd63w"))))
+ "0xldd6cr1w3bn33rdb7yc6p57w143cgnjb48ig1b99iwvvkw599n"))))
(build-system cmake-build-system)
(synopsis "C++ test framework")
(description
@@ -931,6 +933,45 @@ and many external plugins.")
(license license:expat)
(properties `((python2-variant . ,(delay python2-pytest))))))
+(define-public python-pytest-6
+ (package
+ (inherit (strip-python2-variant python-pytest))
+ (version "6.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest" version))
+ (sha256
+ (base32
+ "0gl2sdm322vzmsh5k4f8kj9raiq2y7kdinnca4m45ifvii5fk9y0"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key (tests? #t) #:allow-other-keys)
+ (setenv "TERM" "dumb") ;attempt disabling markup tests
+ (if tests?
+ (invoke "pytest" "-vv" "-k"
+ (string-append
+ ;; This test involve the /usr directory, and fails.
+ " not test_argcomplete"
+ ;; These test do not honor the isatty detection and
+ ;; fail.
+ " and not test_code_highlight"
+ " and not test_color_yes"))
+ (format #t "test suite not run~%"))
+ #t)))))
+ (propagated-inputs
+ (append (alist-delete "python-py"
+ (package-propagated-inputs python-pytest))
+ `(("python-py" ,python-py-next))))
+ (native-inputs
+ (append (alist-delete "python-pytest"
+ (package-native-inputs python-pytest))
+ `(("python-pytest" ,python-pytest-6-bootstrap)
+ ("python-toml" ,python-toml)
+ ("python-iniconfig" ,python-iniconfig))))))
+
;; Pytest 4.x are the last versions that support Python 2.
(define-public python2-pytest
(package
@@ -975,6 +1016,15 @@ and many external plugins.")
(arguments `(#:tests? #f))
(properties `((python2-variant . ,(delay python2-pytest-bootstrap))))))
+(define-public python-pytest-6-bootstrap
+ (package
+ (inherit (strip-python2-variant python-pytest-6))
+ (name "python-pytest-bootstrap")
+ (arguments `(#:tests? #f))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-toml" ,python-toml)))))
+
(define-public python2-pytest-bootstrap
(hidden-package
(package/inherit
@@ -1148,14 +1198,14 @@ same arguments.")
(define-public python-pytest-xdist
(package
(name "python-pytest-xdist")
- (version "1.25.0")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-xdist" version))
(sha256
(base32
- "1d812apvcmshh2l8f38spqwb3bpp0x43yy7lyfpxxzc99h4r7y4n"))
+ "0wh6pn66nncfs6ay0n863bgyriwsgppn8flx5l7551j1lbqkinc2"))
(modules '((guix build utils)))
(snippet
'(begin