summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 45ac7d786c..b2ce42b08c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,6 +65,20 @@ faults or other signals. The output from unit tests can be used within
source code editors and IDEs.")
(license lgpl2.1+)))
+;; XXX: Some packages require this newer version. Incorporate this
+;; into the main 'check' package during the next rebuild cycle.
+(define-public check-0.11.0
+ (package
+ (inherit check)
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/libcheck/check/releases"
+ "/download/" version "/check-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05jn1pgb7hqb937xky2147nnq3r4qy5wwr79rddpax3bms5a9xr4"))))))
+
(define-public cunit
(package
(name "cunit")