summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c1a40c999b..e390bf98aa 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1999,6 +1999,8 @@ exec " gcc "/bin/" program
(arguments
`(#:tests? #f
#:implicit-inputs? #f
+ #:guile ,%bootstrap-guile
+ ,@(package-arguments coreutils)
;; The %bootstrap-glibc for aarch64 and armhf doesn't have
;; $output/include/linux/prctl.h which causes some binaries
;; to fail to build with coreutils-9.0+.
@@ -2008,10 +2010,11 @@ exec " gcc "/bin/" program
;; the defaults to not install.
"arch,coreutils,hostname"
;; fails due to missing headers.
- ",timeout,sort")))
- '())
- #:guile ,%bootstrap-guile
- ,@(package-arguments coreutils)))))
+ ",timeout,sort")
+ ,@(if (target-arm32?)
+ `("--disable-year2038")
+ `())))
+ '())))))
(define diffutils-boot0
(package