summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 1362cd99ca..149d34b24c 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1996,15 +1996,15 @@ exec " gcc "/bin/" program
`(#:tests? #f ; the test suite needs diffutils
#:guile ,%bootstrap-guile
#:implicit-inputs? #f
- ,@(match (%current-system)
- ((or "arm-linux" "aarch64-linux")
- (substitute-keyword-arguments (package-arguments diffutils)
- ((#:configure-flags flags ''())
+ ,@(substitute-keyword-arguments (package-arguments diffutils)
+ ((#:configure-flags flags ''())
+ (match (%current-system)
+ ((or "arm-linux" "aarch64-linux")
;; The generated config.status has some problems due to the
;; bootstrap environment. Disable dependency tracking to work
;; around it.
- `(cons "--disable-dependency-tracking" ,flags))))
- (_ '()))))))
+ `(cons "--disable-dependency-tracking" ,flags))
+ (_ flags))))))))
(define findutils-boot0
(package
@@ -2047,7 +2047,9 @@ exec " gcc "/bin/" program
(substitute* "gnulib-tests/Makefile"
(("^XFAIL_TESTS =")
"XFAIL_TESTS = test-fnmatch ")))))
- '()))))))))
+ '())))
+ ((#:make-flags flags ''())
+ ''()))))))
(define file
(package