summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c7aa59e9a2..7df1d3fca9 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -474,7 +474,7 @@ the bootstrap environment."
(unsetenv "CPATH")
;; Tell 'libpthread' where to find 'libihash' on Hurd systems.
- ,@(if (string-match "i586-gnu" (%current-system))
+ ,@(if (hurd-triplet? (%current-system))
`((substitute* "libpthread/Makefile"
(("LDLIBS-pthread.so =.*")
(string-append "LDLIBS-pthread.so = "
@@ -499,7 +499,7 @@ the bootstrap environment."
,@%boot1-inputs
;; A native MiG is needed to build Glibc on Hurd.
- ,@(if (string-match "i586-gnu" (%current-system))
+ ,@(if (hurd-triplet? (%current-system))
`(("mig" ,mig-boot0))
'())