summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c42185728c..f6bfc27843 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3404,14 +3404,14 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
#:implicit-inputs? #f
#:allowed-references
,@(match (%current-system)
- ("powerpc-linux"
+ ((? target-powerpc?)
`(("out" ,glibc-final ,static-bash-for-glibc)))
(_
`(("out" ,glibc-final))))
,@(package-arguments binutils)))
(inputs
(match (%current-system)
- ("powerpc-linux"
+ ((? target-powerpc?)
`(("bash" ,static-bash-for-glibc)
,@(%boot2-inputs)))
(_ (%boot2-inputs))))))