summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm43
1 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 8b288bb69c..38da6f94df 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -542,7 +542,7 @@ than gzip and 15 % smaller output than bzip2.")
(define-public lhasa
(package
(name "lhasa")
- (version "0.3.1")
+ (version "0.4.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -550,26 +550,25 @@ than gzip and 15 % smaller output than bzip2.")
version "/lhasa-" version ".tar.gz"))
(sha256
(base32
- "092zi9av18ma20c6h9448k0bapvx2plnp292741dvfd9hmgqxc1z"))))
+ "1cy5429c7h1dp4l5y9ncdy40qarl9ix31ylkzdi8al2c60y8iz57"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'set-up-test-environment
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "TZDIR"
- (search-input-directory inputs
- "share/zoneinfo")))))))
- (native-inputs
- (list tzdata-for-tests))
- (home-page "https://fragglet.github.com/lhasa/")
+ (list #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'set-up-test-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZDIR"
+ (search-input-directory inputs
+ "share/zoneinfo")))))))
+ (native-inputs (list tzdata-for-tests))
+ (home-page "https://fragglet.github.io/lhasa/")
(synopsis "LHA archive decompressor")
- (description "Lhasa is a replacement for the Unix LHA tool, for
-decompressing .lzh (LHA / LHarc) and .lzs (LArc) archives. The backend for the
-tool is a library, so that it can be reused for other purposes. Lhasa aims to
-be compatible with as many types of lzh/lzs archives as possible. It also aims
-to generate the same output as the (non-free) Unix LHA tool, so that it will
-act as a free drop-in replacement.")
+ (description
+ "Lhasa is a replacement for the Unix LHa tool, for decompressing
+@file{.lzh} (LHA / LHarc) and .lzs (LArc) archives. The backend for the tool is
+a library, so that it can be reused for other purposes. Lhasa aims to be
+compatible with as many types of @file{.lzh}/@file{lzs} archives as possible.
+It also aims to generate the same output as the (non-free) Unix @command{lha}
+tool, so that it will act as a free drop-in replacement.")
(license license:isc)))
(define-public lzo
@@ -1106,7 +1105,7 @@ tarballs.")
(define-public libjcat
(package
(name "libjcat")
- (version "0.1.12")
+ (version "0.1.14")
(source
(origin
(method git-fetch)
@@ -1116,7 +1115,7 @@ tarballs.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0fbcmnpc0y7s2ls3q829dv3ardhv0m5gxqqmbn0dnkzgkh42vv7p"))))
+ (base32 "0dhyqhs2lg9ka47n8d1lalvic2m3rn5k6mya9bjyw242smkgzpjw"))))
(build-system meson-build-system)
(native-inputs
(list gobject-introspection help2man pkg-config))
@@ -2670,7 +2669,7 @@ to their original, binary CD format.")
(define-public libdeflate
(package
(name "libdeflate")
- (version "1.15")
+ (version "1.19")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2679,7 +2678,7 @@ to their original, binary CD format.")
(file-name (git-file-name name version))
(sha256
(base32
- "001l1xdc3k1dfjvl3ng480ydz0rnyvlhv54l5mshg2p9v4iz3v09"))))
+ "033d8jcaissiy3mk07wx6dap17c1xl768xy75righ22ggmm7c1hy"))))
(build-system cmake-build-system)
(arguments
(list #:configure-flags