summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index dbf4f925a3..c44882b23c 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1661,7 +1661,7 @@ speed.")
(source (package-source zstd))
(build-system gnu-build-system)
(native-inputs
- `(("googletest", googletest)))
+ `(("googletest" ,googletest)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1800,16 +1800,15 @@ recreates the stored directory structure by default.")
(define-public zziplib
(package
(name "zziplib")
- (version "0.13.68")
+ (version "0.13.69")
+ (home-page "https://github.com/gdraheim/zziplib")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/zziplib/zziplib13/"
- version "/zziplib-"
- version ".tar.bz2"))
+ (uri (string-append home-page "/archive/v" version ".tar.gz"))
(sha256
(base32
- "1s0wz1hf2q4qxcp4lkg4rzpbz2814xagmvlyicqdj0ww0cvxv036"))))
+ "0i052a7shww0fzsxrdp3rd7g4mbzx7324a8ysbc0br7frpblcql4"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)))
@@ -1819,16 +1818,12 @@ recreates the stored directory structure by default.")
;; http://forums.gentoo.org/viewtopic-t-863161-start-0.html
("python" ,python-2)
("zip" ,zip))) ; to create test files
- (arguments
- ;; XXX: "make check" is broken, and the alternative (test/zziptests.py)
- ;; requires network access. See <https://github.com/gdraheim/zziplib/issues/20>
- ;; and <https://github.com/gdraheim/zziplib/issues/24>.
- `(#:tests? #f))
- (home-page "http://zziplib.sourceforge.net/")
(synopsis "Library for accessing zip files")
(description
"ZZipLib is a library based on zlib for accessing zip files.")
- (license license:lgpl2.0+)))
+ ;; zziplib is dual licensed under LGPL2.0+ and MPL1.1. Some example source
+ ;; files carry the Zlib license; see "docs/copying.html" for details.
+ (license (list license:lgpl2.0+ license:mpl1.1))))
(define-public perl-archive-zip
(package