summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 287fef33ec..1d643cdff8 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -787,42 +787,43 @@ decompression of some loosely related file formats used by Microsoft.")
(define-public lz4
(package
(name "lz4")
- (version "1.9.2")
+ (version "1.9.3")
(source
(origin
(method git-fetch)
(uri (git-reference (url "https://github.com/lz4/lz4")
(commit (string-append "v" version))))
(sha256
- (base32
- "0lpaypmk70ag2ks3kf2dl4ac3ba40n5kc1ainkp9wfjawz76mh61"))
+ (base32 "1w02kazh1fps3sji2sn89fz862j1199c5ajrqcgl1bnlxj09kcbz"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
+ (outputs (list "out" "static"))
(native-inputs
`(;; For tests.
("python" ,python)
("valgrind" ,valgrind)))
(arguments
`(#:test-target "test"
- ;; TODO: Integrate in next rebuild cycle.
- #:make-flags (list ,(if (%current-target-system)
- (string-append "CC=" (cc-for-target))
- "CC=gcc")
+ #:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "prefix=" (assoc-ref %outputs "out")))
- #:phases (modify-phases %standard-phases
- (delete 'configure) ;no configure script
- (add-before 'check 'disable-broken-test
- (lambda _
- ;; XXX: test_install.sh fails when prefix is a subdirectory.
- (substitute* "tests/Makefile"
- (("^test: (.*) test-install" _ targets)
- (string-append "test: " targets)))
- #t))
- (add-after 'install 'delete-static-library
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (delete-file (string-append out "/lib/liblz4.a"))
- #t))))))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-before 'check 'disable-broken-test
+ (lambda _
+ (substitute* "tests/Makefile"
+ ;; This fails when $prefix is not a single top-level directory.
+ (("^test: (.*) test-install" _ targets)
+ (string-append "test: " targets)))
+ #t))
+ (add-after 'install 'move-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (static (assoc-ref outputs "static")))
+ (mkdir-p (string-append static "/lib"))
+ (rename-file (string-append out "/lib/liblz4.a")
+ (string-append static "/lib/liblz4.a"))
+ #t))))))
(home-page "https://www.lz4.org")
(synopsis "Compression algorithm focused on speed")
(description "LZ4 is a lossless compression algorithm, providing