summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 8a0bd62d6b..03a8a39ee2 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1379,7 +1379,9 @@ point and then, after each tween step, plugging back the result.")
(base32
"1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
(patches
- (search-patches "abseil-cpp-fix-strerror_test.patch"))))
+ (search-patches "abseil-cpp-fix-strerror_test.patch"
+ "abseil-cpp-20200923.3-adjust-sysinfo.patch"
+ "abseil-cpp-20200923.3-duration-test.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
@@ -1454,7 +1456,9 @@ Google's C++ code base.")
(file-name (git-file-name name version))
(sha256
(base32
- "0vxh2a74g4s45yr8kdjqnzl64k10qdlc0hbnn987a4cnwdj4bp9r"))))
+ "0vxh2a74g4s45yr8kdjqnzl64k10qdlc0hbnn987a4cnwdj4bp9r"))
+ (patches
+ (search-patches "abseil-cpp-20220623.1-no-kepsilon-i686.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments base)
((#:configure-flags flags)
@@ -1475,9 +1479,16 @@ Google's C++ code base.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ydkkbanrpkp5i814arzsk973kyzhhjhagnp392rq6rrv16apldq"))))
+ "1ydkkbanrpkp5i814arzsk973kyzhhjhagnp392rq6rrv16apldq"))
+ (patches
+ (search-patches "abseil-cpp-20220623.1-no-kepsilon-i686.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments base)
+ ((#:configure-flags flags #~'())
+ (if (target-riscv64?)
+ #~(cons* "-DCMAKE_SHARED_LINKER_FLAGS=-latomic"
+ #$flags)
+ flags))
((#:phases phases)
#~(modify-phases #$phases
(add-before 'check 'set-env-vars
@@ -1572,6 +1583,8 @@ parsers according to a Parsing Expression Grammar (PEG).")
external-memory suffix array construction algorithm called pSAscan. The
algorithm is based on the sequential external-memory suffix array construction
algorithm called SAscan.")
+ ;; Code exhibits integer size mismatches when compiled on 32-bit systems.
+ (supported-systems %64bit-supported-systems)
(license license:expat)))
(define-public cxxopts