summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm68
1 files changed, 67 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 4fd499f5f3..3e9c39df61 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1,6 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
+;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,9 +23,15 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
- #:use-module (gnu packages autotools))
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages tls))
(define-public libzen
(package
@@ -58,3 +66,61 @@
strings, configuration, bit streams, threading, translation, and cross-platform
operating system functions.")
(license license:zlib)))
+
+(define-public rct
+ (let* ((commit "b3e6f41d9844ef64420e628e0c65ed98278a843a")
+ (revision "2")
+ (version (git-version "0.0.0" revision commit)))
+ (package
+ (name "rct")
+ (version version)
+ (home-page "https://github.com/Andersbakken/rct")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "1m2931jacka27ghnpgf1z1plkkr64z0pga4r4zdrfpp2d7xnrdvb"))
+ (patches (search-patches "rct-add-missing-headers.patch"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DWITH_TESTS=ON" ; To run the test suite
+ "-DRCT_RTTI_ENABLED=ON")))
+ (native-inputs
+ `(("cppunit" ,cppunit)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (synopsis "C++ library providing Qt-like APIs on top of the STL")
+ (description "Rct is a set of C++ tools that provide nicer (more Qt-like)
+ APIs on top of Standard Template Library (@dfn{STL}) classes.")
+ (license (list license:expat ; cJSON
+ license:bsd-4))))) ; everything else (LICENSE.txt)
+
+(define-public dashel
+ (package
+ (name "dashel")
+ (version "1.3.3")
+ (home-page "https://github.com/aseba-community/dashel")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append home-page "/archive/" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ckzac1rsw3cxmpdpwcqv46jyp7risk5ybq6jjiizbqn7labf6dw"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ;no tests
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "Data stream helper encapsulation library")
+ (description
+ "Dashel is a data stream helper encapsulation C++ library. It provides a
+unified access to TCP/UDP sockets, serial ports, console, and files streams.
+It also allows a server application to wait for any activity on any
+combination of these streams.")
+ (license license:bsd-3)))