summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d4564f4f49..03aa2f59f5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12669,3 +12669,27 @@ SELECT or UPDATE queries to an end-point.")
;; The only license indication is found in the DESCRIPTION file,
;; which states GPL-3. So we cannot assume GPLv3+.
(license license:gpl3)))
+
+(define-public r-bookdown
+ (package
+ (name "r-bookdown")
+ (version "0.9")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "bookdown" version))
+ (sha256
+ (base32
+ "0vg1s1w0l9pm95asqb21yf39mfk1nc9rdhmlys9xwr7p7i7rsz32"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-tinytex" ,r-tinytex)
+ ("r-yaml" ,r-yaml)
+ ("r-xfun" ,r-xfun)))
+ (home-page "https://github.com/rstudio/bookdown")
+ (synopsis "Authoring books and technical documents with R markdown")
+ (description "This package provides output formats and utilities for
+authoring books and technical documents with R Markdown.")
+ (license license:gpl3)))