summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 03aa2f59f5..8bf5404a0c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12693,3 +12693,25 @@ SELECT or UPDATE queries to an end-point.")
(description "This package provides output formats and utilities for
authoring books and technical documents with R Markdown.")
(license license:gpl3)))
+
+(define-public r-optparse
+ (package
+ (name "r-optparse")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "optparse" version))
+ (sha256
+ (base32
+ "04vyb6dhcga30mvghsg1p052jmf69xqxkvh3hzqz7dscyppy76w1"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-getopt" ,r-getopt)))
+ (home-page "https://github.com/trevorld/optparse")
+ (synopsis "Command line option parser")
+ (description
+ "This package provides a command line parser inspired by Python's
+@code{optparse} library to be used with Rscript to write shebang scripts
+that accept short and long options.")
+ (license license:gpl2+)))