summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a2834d88f9..aaadc76c16 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022-2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2024 Marco Baggio <guix@mawumag.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -15775,6 +15776,27 @@ the analyzed items.")
based on index arrays and simple triplet representations, respectively.")
(license license:gpl2)))
+(define-public r-slanter
+ (package
+ (name "r-slanter")
+ (version "0.2-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "slanter" version))
+ (sha256
+ (base32 "024dkman0r5qzc215gw0ds932vdaz8krrhv64fjw9pni37ixc3mf"))))
+ (properties `((upstream-name . "slanter")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-matrix r-pheatmap r-pracma))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=slanter")
+ (synopsis "Slanted matrices and ordered clustering")
+ (description
+ "This is a package for slanted matrices and ordered clustering for better
+visualization of similarity data.")
+ (license license:expat)))
+
(define-public r-manipulatewidget
(package
(name "r-manipulatewidget")