summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm244
1 files changed, 141 insertions, 103 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 023d726fe0..8709cd21fa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -132,14 +132,14 @@ files and provide more explicit control over line endings.")
(define-public r-cachem
(package
(name "r-cachem")
- (version "1.0.4")
+ (version "1.0.5")
(source
(origin
(method url-fetch)
(uri (cran-uri "cachem" version))
(sha256
(base32
- "1b1gk837rk9kbfq385ybrrk12ckxwvhjvf0z9635l3vw49wal4mh"))))
+ "1xigqfhkl4n768bjgn2bqvb9k70h1ibj4lv5vvpwsh1p6vw4mkw2"))))
(properties `((upstream-name . "cachem")))
(build-system r-build-system)
(propagated-inputs
@@ -1207,13 +1207,13 @@ models.")
(define-public r-httpuv
(package
(name "r-httpuv")
- (version "1.6.0")
+ (version "1.6.1")
(source (origin
(method url-fetch)
(uri (cran-uri "httpuv" version))
(sha256
(base32
- "01i0x9234fsyinzfjyl9a807kyvb0nivr6jx9911fp0msdmy1vkm"))
+ "0rxy57zl8yb5amsn3pvikha04k2vk0py4gys09lc7wr3agamswva"))
;; Unvendor bundled libraries. As of 1.5.4 the vendored libuv
;; only contains fixes for building on Solaris.
(patches (search-patches "r-httpuv-1.5.5-unvendor-libuv.patch"))
@@ -1356,13 +1356,13 @@ applications.")
(define-public r-htmltable
(package
(name "r-htmltable")
- (version "2.1.0")
+ (version "2.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "htmlTable" version))
(sha256
- (base32 "1gzh0bdxi55p1ckxv4k0a41b1j0grwv2w3lkqz4c3gkw66dk6ja0"))))
+ (base32 "05zy9acx4s80dr880q69i4rcjqgmbz18gn7pyazda9gsnm981j96"))))
(properties `((upstream-name . "htmlTable")))
(build-system r-build-system)
(propagated-inputs
@@ -1612,19 +1612,18 @@ jQuery.")
(define-public r-sass
(package
(name "r-sass")
- (version "0.3.1")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "sass" version))
(sha256
(base32
- "1cxqwsdyz71mgflqqa65mfr161jlv8q9mshs1y19pxp6pz5wnv0s"))))
+ "0axw358bbk3vxsqg3wq0bz3xigasa6af8fxvi2ga8hli4cawl1kx"))))
(properties `((upstream-name . "sass")))
(build-system r-build-system)
(propagated-inputs
- `(("r-digest" ,r-digest)
- ("r-fs" ,r-fs)
+ `(("r-fs" ,r-fs)
("r-htmltools" ,r-htmltools)
("r-r6" ,r-r6)
("r-rappdirs" ,r-rappdirs)
@@ -1644,14 +1643,14 @@ language, which is stable, powerful, and CSS compatible.")
(define-public r-bslib
(package
(name "r-bslib")
- (version "0.2.4")
+ (version "0.2.5.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "bslib" version))
(sha256
(base32
- "0qlpv2lqr3hjykszmnll7vi4zhmrz4rgcfl0sifxc6cha6jy2nac"))
+ "16f8d7lp2bdq1vipr60l75gibgdq08hmx212dhrh66nwf7qglhky"))
(snippet
'(for-each delete-file
'("inst/lib/bs-a11y-p/plugins/js/bootstrap-accessibility.min.js"
@@ -1688,8 +1687,7 @@ language, which is stable, powerful, and CSS compatible.")
(string-append "--outfile=" target)))
sources targets)))))))))
(propagated-inputs
- `(("r-digest" ,r-digest)
- ("r-htmltools" ,r-htmltools)
+ `(("r-htmltools" ,r-htmltools)
("r-jquerylib" ,r-jquerylib)
("r-jsonlite" ,r-jsonlite)
("r-magrittr" ,r-magrittr)
@@ -2653,13 +2651,13 @@ XML. To learn more about the Abbyy OCR API, see @url{http://ocrsdk.com/}.")
(define-public r-colorspace
(package
(name "r-colorspace")
- (version "2.0-0")
+ (version "2.0-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "colorspace" version))
(sha256
- (base32 "13h1hara0s6xn16bgkrbd0flszah1yiylwfwxwn2inqqk6pm6sjf"))))
+ (base32 "0pj2hji71c18kwwk1pp2fj6s4jl7lm2yn47ls0dqsrsqc3ixsbzq"))))
(build-system r-build-system)
(native-inputs
`(("r-knitr" ,r-knitr)))
@@ -3030,14 +3028,14 @@ on (non-orthogonal) variable vectors in scatterplots and biplots.")
(define-public r-shape
(package
(name "r-shape")
- (version "1.4.5")
+ (version "1.4.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "shape" version))
(sha256
(base32
- "17qqhjyfhxv9la07ykaslb50c8g4d0cgfypx4y91h9i2yjw7jjh9"))))
+ "0yqbrrx2ywmfl99s6d1n6jblc63k1mxbiqyv8y0kq8jws1g3w45r"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/shape")
(synopsis "Functions for plotting graphical shapes")
@@ -3149,14 +3147,14 @@ rows, dropping names) to see if the modified versions are identical.")
(define-public r-dendextend
(package
(name "r-dendextend")
- (version "1.14.0")
+ (version "1.15.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "dendextend" version))
(sha256
(base32
- "0n3qg76apgbqbvxv2yp5qwpy6nx03xmmc9mdfyq4dqblqhdld29p"))))
+ "0zf4w4rc2jj30i3x0m0gnkwidfmn3cvz1wirp20amq4v3n9420md"))))
(build-system r-build-system)
(propagated-inputs
`(("r-ggplot2" ,r-ggplot2)
@@ -3546,14 +3544,14 @@ quantile mixture from L-moments and trimmed L-moments.")
(define-public r-distillery
(package
(name "r-distillery")
- (version "1.2")
+ (version "1.2-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "distillery" version))
(sha256
(base32
- "10nhh9p0hp294pp4aav0y0zsmir2qbn05sf3k52rmzmm36q2kc8y"))))
+ "1ymmxyamkq0zbz2m4gllln1ihks2hcib6gs0mls92as79srz122b"))))
(build-system r-build-system)
(home-page "https://ral.ucar.edu/staff/ericg/")
(synopsis "Functions for confidence intervals and object information")
@@ -3655,13 +3653,13 @@ by Li, Brown, Huang, and Bickel")
(define-public r-inline
(package
(name "r-inline")
- (version "0.3.17")
+ (version "0.3.18")
(source (origin
(method url-fetch)
(uri (cran-uri "inline" version))
(sha256
(base32
- "1wslsn60q959yrr27cwanba43qlpfaxzdli46i9dc26lxfr5fa3r"))))
+ "0fpcfwbhfg1lhkqc0gdqv2sq64r3ljld7piy34vv0nimq30xi2fc"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/inline")
(synopsis "Functions to inline C, C++, Fortran function calls from R")
@@ -4553,15 +4551,17 @@ from the data points.")
(define-public r-corrplot
(package
(name "r-corrplot")
- (version "0.84")
+ (version "0.88")
(source
(origin
(method url-fetch)
(uri (cran-uri "corrplot" version))
(sha256
(base32
- "1k03qd8db7pwg1v318xapx5mpiypiz2n07qr19c4b45diri5xkhd"))))
+ "1s09isdpx2i4p6jny50lck37bsqd5dfxdi3yn8xq8280x8l4vldz"))))
(build-system r-build-system)
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/taiyun/corrplot")
(synopsis "Visualization of a correlation matrix")
(description
@@ -5404,13 +5404,13 @@ iVAT).")
(define-public r-xfun
(package
(name "r-xfun")
- (version "0.22")
+ (version "0.23")
(source
(origin
(method url-fetch)
(uri (cran-uri "xfun" version))
(sha256
- (base32 "0ix3p0iw2c60whn5mvsflh0vhm4yixhw4s9d9v4023qhp077nw9y"))))
+ (base32 "0dqfhpnj9yxk42mx96dvhv2qs35in36mk0qls3dg7rx7bvl2i1gc"))))
(build-system r-build-system)
;; knitr itself depends on xfun
#;
@@ -5507,14 +5507,14 @@ to variables on the left-hand side of the assignment.")
(define-public r-pillar
(package
(name "r-pillar")
- (version "1.6.0")
+ (version "1.6.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "pillar" version))
(sha256
(base32
- "1pfa6q63ji6mqsvkbpjvvlaivw66nyinwbk82jh0a0c6dy41w47i"))))
+ "0akjk2k98zy4lyvw5ji1qlrrwzx43vad8z042jydn0f3i1hvkdq8"))))
(build-system r-build-system)
(propagated-inputs
`(("r-cli" ,r-cli)
@@ -6083,14 +6083,14 @@ applied econometric analysis.")
(define-public r-cubature
(package
(name "r-cubature")
- (version "2.0.4.1")
+ (version "2.0.4.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "cubature" version))
(sha256
(base32
- "006la36gxdikvmdnq4ny7ik7r30id4z3b3fqsl57dpqwkpsbsgrq"))))
+ "0kk9lw3s66h0sayza3in8rdj7bmgqn4v5lfckhslarpvj2fxsnv0"))))
(build-system r-build-system)
(propagated-inputs
`(("r-rcpp" ,r-rcpp)))
@@ -6851,14 +6851,14 @@ evaluated by the @dfn{Akaike Information Criterion} (AIC).")
(define-public r-arules
(package
(name "r-arules")
- (version "1.6-7")
+ (version "1.6-8")
(source
(origin
(method url-fetch)
(uri (cran-uri "arules" version))
(sha256
(base32
- "0m80kndfbannw8h53nqdd5wl8h33q2z259aa1cp1nwadaxf9fc1q"))))
+ "1gy6wrys1qqik65dyr325hdbfmd3fx9a2lzdnrr29g751hprjx2l"))))
(build-system r-build-system)
(propagated-inputs
`(("r-matrix" ,r-matrix)))
@@ -8249,14 +8249,14 @@ and tests them.")
(define-public r-overlap
(package
(name "r-overlap")
- (version "0.3.3")
+ (version "0.3.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "overlap" version))
(sha256
(base32
- "17cnr4qin1qy0df4k491267acna12gpbbps6w3gi8nccqxfrb1pd"))))
+ "1arxprhz035ab78ks88n6scwnlwmnb97mlac5gsx90ipb6gkgcyk"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/overlap/")
(synopsis "Estimates of coefficient of overlapping for animal activity patterns")
@@ -8316,14 +8316,14 @@ other add-on packages.")
(define-public r-insight
(package
(name "r-insight")
- (version "0.13.2")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "insight" version))
(sha256
(base32
- "03b7kd17h25mi1si40ibcp3jpasyqpj51mr8js0ywywyfw7909j1"))))
+ "1zkifkj2qg9vdv26z4qvi81qv9l1cqyrq3ihdpacpax80plkgdln"))))
(build-system r-build-system)
(native-inputs
`(("r-knitr" ,r-knitr)))
@@ -8344,14 +8344,14 @@ information are missing.")
(define-public r-sjlabelled
(package
(name "r-sjlabelled")
- (version "1.1.7")
+ (version "1.1.8")
(source
(origin
(method url-fetch)
(uri (cran-uri "sjlabelled" version))
(sha256
(base32
- "0d3fsjd2gxchv8mlx9l5pf8xvkmx4pgvizam83f3qss07bmvpzwg"))))
+ "17gskxr43rgbg7syla3b78g2qgksq2kj07iad4139xycqxblxya0"))))
(build-system r-build-system)
(propagated-inputs
`(("r-insight" ,r-insight)))
@@ -8370,14 +8370,14 @@ vice versa), or to deal with multiple declared missing values.")
(define-public r-sjmisc
(package
(name "r-sjmisc")
- (version "2.8.6")
+ (version "2.8.7")
(source
(origin
(method url-fetch)
(uri (cran-uri "sjmisc" version))
(sha256
(base32
- "1nfrkv5jfnwb85blpv7yk7xac1myzi2c30bqcf7xicniknkjwycr"))))
+ "17hcjb2j690qi2zrkwc14sr1wsid6dy6v7bfsf0bc94ql812k8g2"))))
(build-system r-build-system)
(propagated-inputs
`(("r-dplyr" ,r-dplyr)
@@ -8452,14 +8452,14 @@ functions.")
(define-public r-flextable
(package
(name "r-flextable")
- (version "0.6.5")
+ (version "0.6.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "flextable" version))
(sha256
(base32
- "1njk4kc19r2n2awxjfz4svf1pivxhn12r9dqsdvbdpbfl5wmvxzl"))))
+ "1f4yb2sgy6m0y2s5jcxa3vpbizyc72qj1n8i3vi2a4pjhnv3bn2g"))))
(build-system r-build-system)
(propagated-inputs
`(("r-base64enc" ,r-base64enc)
@@ -10188,14 +10188,14 @@ observation.")
(define-public r-sandwich
(package
(name "r-sandwich")
- (version "3.0-0")
+ (version "3.0-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "sandwich" version))
(sha256
(base32
- "0afm6snak7r11dxyl3qirqdjah6d9pdv4afmxwam1nq9bqxyb3w2"))))
+ "12aa5083k3sfrfq1jy3l94wffss9h0rga8j71jy3n8pkhiq4nn7n"))))
(build-system r-build-system)
(propagated-inputs
`(("r-zoo" ,r-zoo)))
@@ -10524,14 +10524,14 @@ ROPE percentage and pd).")
(define-public r-performance
(package
(name "r-performance")
- (version "0.7.1")
+ (version "0.7.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "performance" version))
(sha256
(base32
- "1kf8z7lrjv1bg8mqb7sq4651k2xg3d02azq7gr0jc4c52cr2yaqm"))))
+ "1yfbf7cp4nqwh5mcnm008vw3dapr5v3yj4lq81pvlwblp9hg7y94"))))
(build-system r-build-system)
(propagated-inputs
`(("r-bayestestr" ,r-bayestestr)
@@ -11376,14 +11376,14 @@ package provides a minimal R interface by relying on the Rcpp package.")
(define-public r-rcppparallel
(package
(name "r-rcppparallel")
- (version "5.1.3")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "RcppParallel" version))
(sha256
(base32
- "1c3y80m695xqhs4ynwig2bsl045nryi9ww0a1s2rb3gsjbs5vx7v"))))
+ "10pa9vaz7p4m6hjca2cpy6vj7rvgly4zv0q1g2xfsmcchyk4bdbn"))))
(properties `((upstream-name . "RcppParallel")))
(build-system r-build-system)
(home-page "https://rcppcore.github.io/RcppParallel/")
@@ -11426,13 +11426,13 @@ netCDF files.")
(define-public r-biocmanager
(package
(name "r-biocmanager")
- (version "1.30.12")
+ (version "1.30.15")
(source
(origin
(method url-fetch)
(uri (cran-uri "BiocManager" version))
(sha256
- (base32 "0c2anza01pc36manj3cvycbq8p57qpq18dsimk3y3gpks70hhqf3"))))
+ (base32 "1mbz04ja4dsp8gs74ybmba7kcn9dkc5bvdqnlgn1wwq4y5xizk7m"))))
(properties `((upstream-name . "BiocManager")))
(build-system r-build-system)
(native-inputs
@@ -11668,14 +11668,14 @@ circular variables).")
(define-public r-ouch
(package
(name "r-ouch")
- (version "2.16")
+ (version "2.17")
(source
(origin
(method url-fetch)
(uri (cran-uri "ouch" version))
(sha256
(base32
- "17y7qksp9v4jkr4h1psg14y3ridwhi4mgkfm0a02paabhwjc8d96"))))
+ "1a7r24j59xz3lxa5wc694j6b80j8m5l86zd1sw9pvs66l8gd98kf"))))
(build-system r-build-system)
(propagated-inputs `(("r-subplex" ,r-subplex)))
(home-page "https://kingaa.github.io/ouch/")
@@ -11688,14 +11688,14 @@ for evolution along a phylogenetic tree.")
(define-public r-fmsb
(package
(name "r-fmsb")
- (version "0.7.0")
+ (version "0.7.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "fmsb" version))
(sha256
(base32
- "0x1wkzfdvv4s5xmr0whcwjz4aac71gacwymj2c3mzj2bbswwlw45"))))
+ "09pq7p7i6vkq9av7l7x9hicl9sqh7xn96f9pac117hy6z852jvi2"))))
(build-system r-build-system)
(home-page "http://minato.sip21c.org/msb/")
(synopsis "Functions for medical statistics book with demographic data")
@@ -11799,20 +11799,21 @@ after it was discovered that the NSA had backdoored Dual EC DRBG.")
(define-public r-softimpute
(package
(name "r-softimpute")
- (version "1.4")
+ (version "1.4-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "softImpute" version))
(sha256
(base32
- "07cxbzkl08q58m1455i139952rmryjlic4s2f2hscl5zxxmfdxcq"))))
+ "1v2a4d688ij5zcvkzpra9yx40xckdfnllnfnyq2450zf3n1kjk7a"))))
(properties `((upstream-name . "softImpute")))
(build-system r-build-system)
(propagated-inputs
`(("r-matrix" ,r-matrix)))
(native-inputs
- `(("gfortran" ,gfortran)))
+ `(("gfortran" ,gfortran)
+ ("r-knitr" ,r-knitr)))
(home-page "https://cran.r-project.org/web/packages/softImpute")
(synopsis "Matrix completion via iterative soft-thresholded SVD")
(description
@@ -12387,14 +12388,14 @@ Touzet and Varre (2007).")
(define-public r-rnifti
(package
(name "r-rnifti")
- (version "1.3.0")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "RNifti" version))
(sha256
(base32
- "1zr0q79id62csmc30c7gs4hbmavk8n6p50a981sfz51dczhjj5ny"))))
+ "0bz10ar6hrgkvlzh9j2im24kwi3s2nnax668z40a2wj6s5xghqlr"))))
(properties `((upstream-name . "RNifti")))
(build-system r-build-system)
(propagated-inputs `(("r-rcpp" ,r-rcpp)))
@@ -13361,17 +13362,18 @@ Differences with other sparse matrix packages are:
(define-public r-fields
(package
(name "r-fields")
- (version "11.6")
+ (version "12.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "fields" version))
(sha256
- (base32 "1nsrgkw9w3mwd3sajyzc06h49gg1s0bkq6xh5b66h1n4jbcx2046"))))
+ (base32 "17dsnims2bjcpqsxcv63vkm8rjdmcmq10m00x15yvr4kk0p0aznr"))))
(build-system r-build-system)
(propagated-inputs
`(("r-maps" ,r-maps)
- ("r-spam" ,r-spam)))
+ ("r-spam" ,r-spam)
+ ("r-viridis" ,r-viridis)))
(native-inputs
`(("gfortran" ,gfortran)))
(home-page "https://www.image.ucar.edu/fields")
@@ -14825,14 +14827,14 @@ running IRkernel session.")
(define-public r-irkernel
(package
(name "r-irkernel")
- (version "1.1.1")
+ (version "1.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "IRkernel" version))
(sha256
(base32
- "1y06v3difaiihxfm2abm88nnjzvkla4p346cm1nxmga4iwb2k8gm"))))
+ "14gz3790iv6gg6yi9wslk1yn0jq57yvhxgm840qh818xfkdxpd2z"))))
(properties `((upstream-name . "IRkernel")))
(build-system r-build-system)
(arguments
@@ -14923,14 +14925,14 @@ plotting functions are available for analyzing clustering results.")
(define-public r-valr
(package
(name "r-valr")
- (version "0.6.2")
+ (version "0.6.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "valr" version))
(sha256
(base32
- "1vbp89zfylgih5acvw7lcx3a0dbbd7dhq7yhywr7kq02737qykdx"))))
+ "1lzdlw0mw06rymyjzwf4i8rx1z6zxpwxxqfsc9ggqlnhq6bfhy93"))))
(build-system r-build-system)
(propagated-inputs
`(("r-broom" ,r-broom)
@@ -15567,13 +15569,13 @@ also provided to illustrate various methods.")
(define-public r-pegas
(package
(name "r-pegas")
- (version "1.0")
+ (version "1.0-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "pegas" version))
(sha256
- (base32 "0nbdcrpha2r50gp0nymr4lqmqhd4237rzz6ank8cqdhl7lcsz69v"))))
+ (base32 "0ykx84p7c8cad5d1mj8cm1d5cz2paacdjx4ll4qzmq827lcyycz1"))))
(build-system r-build-system)
(propagated-inputs
`(("r-adegenet" ,r-adegenet)
@@ -16309,20 +16311,52 @@ The extrafont package makes both of these things easier.")
the XKCD web comic.")
(license license:gpl3)))
+(define-public r-babelgene
+ (package
+ (name "r-babelgene")
+ (version "21.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "babelgene" version))
+ (sha256
+ (base32
+ "1gk5pm3b3shr1id66a11ywc1b823gbj8yckg24szzfhj8g4ixyf0"))))
+ (properties `((upstream-name . "babelgene")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-rlang" ,r-rlang)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://igordot.github.io/babelgene/")
+ (synopsis "Gene orthologs for model organisms in a Tidy data format")
+ (description
+ "Genomic analysis of model organisms often requires the use of databases
+based on human data or making comparisons to patient-derived resources. This
+requires converting genes between human and non-human analogues. The
+babelgene R package provides predicted gene orthologs/homologs for frequently
+studied model organisms in an R-friendly tidy/long format. The package
+integrates orthology assertion predictions sourced from multiple databases as
+compiled by the HGNC Comparison of Orthology Predictions (HCOP).")
+ (license license:expat)))
+
(define-public r-msigdbr
(package
(name "r-msigdbr")
- (version "7.2.1")
+ (version "7.4.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "msigdbr" version))
(sha256
(base32
- "1rc2p9vw57pn4prmfgay4w18qd53ggq7wxfsi9kp7w25ciip1dq1"))))
+ "103m52av68pkjfh8f81qh6j3cs1mj1lg831ciwybr34cax767jr1"))))
(build-system r-build-system)
(propagated-inputs
- `(("r-dplyr" ,r-dplyr)
+ `(("r-babelgene" ,r-babelgene)
+ ("r-dplyr" ,r-dplyr)
("r-magrittr" ,r-magrittr)
("r-rlang" ,r-rlang)
("r-tibble" ,r-tibble)
@@ -16393,14 +16427,14 @@ package.")
(define-public r-ggplotify
(package
(name "r-ggplotify")
- (version "0.0.6")
+ (version "0.0.7")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggplotify" version))
(sha256
(base32
- "1xs9l05hzlrgcr0p0xah2b05fbm64ma3vfwzn4p8q6nj7xch1dbd"))))
+ "1vx2fg91ivssrxr4kzs9737hr8bsfs0q5pvd7lck7ffjpkjbclhh"))))
(build-system r-build-system)
(propagated-inputs
`(("r-ggplot2" ,r-ggplot2)
@@ -17610,14 +17644,14 @@ feature effects. Key functions are:
(define-public r-ibreakdown
(package
(name "r-ibreakdown")
- (version "1.3.1")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "iBreakDown" version))
(sha256
(base32
- "1bfl5bh0x6z5a0cmdmx68sap9zdxa3kwdnyk57csxapc362yz108"))))
+ "00jzrndb3ahsv6ihp2pvs732n9cc944m83vdinrl9v1pxd82prkh"))))
(properties `((upstream-name . "iBreakDown")))
(build-system r-build-system)
(propagated-inputs `(("r-ggplot2" ,r-ggplot2)))
@@ -18274,14 +18308,14 @@ both R code and compiled C/C++/FORTRAN code.")
(define-public r-systemfonts
(package
(name "r-systemfonts")
- (version "1.0.1")
+ (version "1.0.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "systemfonts" version))
(sha256
(base32
- "15x7qx8iigkybgz6b6s66i3mh75vgynzpd50nw05wflfwzcv87a0"))))
+ "1a9nzd4nqawr6ni3mw7xc2yq77fb2f91aarnc906mq26510rdb11"))))
(properties `((upstream-name . "systemfonts")))
(build-system r-build-system)
(propagated-inputs
@@ -18332,14 +18366,14 @@ emphasize hidden group structures in networks or focus on specific nodes.")
(define-public r-terra
(package
(name "r-terra")
- (version "1.2-5")
+ (version "1.2-10")
(source
(origin
(method url-fetch)
(uri (cran-uri "terra" version))
(sha256
(base32
- "0wmrb75y271xdx781xql0dx702ghnj4d2i2zr9375kqjbwgx9nad"))))
+ "0k2rwmfc07c9ipvd15mrfgw7yx61alf0zmyskkgrb0d1rf66n3id"))))
(properties `((upstream-name . "terra")))
(build-system r-build-system)
(inputs
@@ -18711,18 +18745,20 @@ as a boxplot function.")
(define-public r-bio3d
(package
(name "r-bio3d")
- (version "2.4-1")
+ (version "2.4-2")
(source
(origin
(method url-fetch)
(uri (cran-uri "bio3d" version))
(sha256
(base32
- "07rw6c2d95gb5myxh31727j0jrchd0xisa3x89jjmf4zzs3vv7v7"))))
+ "1jvcmpzi9knhxq5jsbhg8slm8hnlx2y8smmwwrbnbyd0rmk5fhci"))))
(properties `((upstream-name . "bio3d")))
(build-system r-build-system)
(inputs `(("zlib" ,zlib)))
(propagated-inputs `(("r-rcpp" ,r-rcpp)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "http://thegrantlab.org/bio3d/")
(synopsis "Biological structure analysis")
(description
@@ -21133,14 +21169,14 @@ it may be seen by an animal with less acute vision.")
(define-public r-caret
(package
(name "r-caret")
- (version "6.0-86")
+ (version "6.0-88")
(source
(origin
(method url-fetch)
(uri (cran-uri "caret" version))
(sha256
(base32
- "0dyflixdw98lvk2x3w136sw24ij0fwx5c7l709dmqr5z7xy1qjns"))))
+ "174cyyhsw8s6jp80spmi40qq9sw5ys0r58v4ikp53kiw1dhd247s"))))
(build-system r-build-system)
(propagated-inputs
`(("r-foreach" ,r-foreach)
@@ -22116,14 +22152,14 @@ programming} (OOP) using R Reference Class.")
(define-public r-proxyc
(package
(name "r-proxyc")
- (version "0.1.5")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "proxyC" version))
(sha256
(base32
- "159bc42x4shm6n3rh9fc8ziv3ivq0ipmpbasrh279hhn1prc8gg6"))))
+ "08h79wzk8hp5yn3sxy1jcd1yljj25s7fac96l2jqavwd026y6j3l"))))
(properties `((upstream-name . "proxyC")))
(build-system r-build-system)
(propagated-inputs
@@ -23718,13 +23754,13 @@ rendered as text, axis labels, etc. throughout R's plotting system.")
(define-public r-oai
(package
(name "r-oai")
- (version "0.3.0")
+ (version "0.3.2")
(source (origin
(method url-fetch)
(uri (cran-uri "oai" version))
(sha256
(base32
- "1ipw9bq3ra66d1ddj1rylyyd20mlcb2i7phzhywra53s1fdifq1g"))))
+ "1zcbcxhw692s0y6izvwazyzhgx0iwsxsbcan2nk0mb7n11p7bypb"))))
(build-system r-build-system)
(propagated-inputs
`(("r-xml2" ,r-xml2)
@@ -23732,6 +23768,8 @@ rendered as text, axis labels, etc. throughout R's plotting system.")
("r-plyr" ,r-plyr)
("r-stringr" ,r-stringr)
("r-tibble" ,r-tibble)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/ropensci/oai/")
(synopsis "General purpose OAI-PMH services client")
(description "@code{oai} provides a general purpose client to work with
@@ -25225,14 +25263,14 @@ aggregation for comparing different implementations in order to provide a
(define-public r-rfast
(package
(name "r-rfast")
- (version "2.0.1")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "Rfast" version))
(sha256
(base32
- "1cq3mcg49hsvqhwn6f4dgsx7f8ma4qnwr5n6s7m22qy57rg31958"))))
+ "1bmhmli6q4kg8321595k0yy91w9cblk14s6qbc9wf8f05108rg15"))))
(properties `((upstream-name . "Rfast")))
(build-system r-build-system)
(propagated-inputs
@@ -25251,14 +25289,14 @@ Poisson), are some of the many fast functions.")
(define-public r-clusterr
(package
(name "r-clusterr")
- (version "1.2.3")
+ (version "1.2.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "ClusterR" version))
(sha256
(base32
- "19xphxcpia7pdshn09yd328q3rbr6frz5574688ja1z7g5hsa2p7"))))
+ "01vgr1mpm7l1lyhril5hm1l72aicqc4iwb0b15ypijb6hwkv7g47"))))
(properties `((upstream-name . "ClusterR")))
(build-system r-build-system)
(propagated-inputs
@@ -25933,14 +25971,14 @@ sliding windows are to be created.")
(define-public r-rsample
(package
(name "r-rsample")
- (version "0.0.9")
+ (version "0.1.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "rsample" version))
(sha256
(base32
- "03qwsvylgmj2a2h764mzy0x57pgzmvjvl0ypmbn4lcf912bvrd2c"))))
+ "00w8r0p499fm8cyw297gznr83mbgy9a3znzpbgj0zq9dry1a266b"))))
(properties `((upstream-name . "rsample")))
(build-system r-build-system)
(propagated-inputs
@@ -25948,6 +25986,7 @@ sliding windows are to be created.")
("r-ellipsis" ,r-ellipsis)
("r-furrr" ,r-furrr)
("r-generics" ,r-generics)
+ ("r-lifecycle" ,r-lifecycle)
("r-purrr" ,r-purrr)
("r-rlang" ,r-rlang)
("r-slider" ,r-slider)
@@ -26728,22 +26767,21 @@ data to rasters. It speeds up plotting of data with millions of points.")
(define-public r-seuratobject
(package
(name "r-seuratobject")
- (version "4.0.0")
+ (version "4.0.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "SeuratObject" version))
(sha256
(base32
- "03k27z7g76wy7mfja2cpxq183xk0906k9gxb2j6p1zw341gv4gii"))))
+ "0g32ivx7g64a1sbxc5ym1832wh14w22z025lzyasn8yn2769c1f9"))))
(properties `((upstream-name . "SeuratObject")))
(build-system r-build-system)
(propagated-inputs
`(("r-matrix" ,r-matrix)
("r-rcpp" ,r-rcpp)
("r-rcppeigen" ,r-rcppeigen)
- ("r-rlang" ,r-rlang)
- ("r-sctransform" ,r-sctransform)))
+ ("r-rlang" ,r-rlang)))
(home-page "https://satijalab.org/seurat")
(synopsis "Data structures for single cell data")
(description
@@ -27543,14 +27581,14 @@ clusterings as resolution increases.")
(define-public r-textshaping
(package
(name "r-textshaping")
- (version "0.3.3")
+ (version "0.3.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "textshaping" version))
(sha256
(base32
- "0yl3cv6r8k27h4lzbrsikjydhz94skdjmxx4zqzihvb7h3jfnlpn"))))
+ "1kr6rh5zb5jp3acsfah6bzwkypzl5ixjzrs1xpdcslq14n82j4s0"))))
(properties `((upstream-name . "textshaping")))
(build-system r-build-system)
(inputs
@@ -28110,14 +28148,14 @@ data you need the @code{pdftools} package.")
(define-public r-pdftools
(package
(name "r-pdftools")
- (version "2.3.1")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "pdftools" version))
(sha256
(base32
- "01i5g2mjkshis0zlm7lrvi7kkzl4dn3if1hzwkgzf9n2mi33ndsx"))))
+ "1dcbs5n5y8zi7bbyx491m9ik8kkmjr301x8ms85fmwdfb5a97m8k"))))
(properties `((upstream-name . "pdftools")))
(build-system r-build-system)
(inputs