summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 00d141e100..aa23bc42d5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10701,7 +10701,8 @@ with Clap to generate Fig completion scripts.")
(home-page "https://github.com/clap-rs/clap/tree/master/clap_lex")
(synopsis "Command line parser for Clap")
(description
- "This package provides a parser for command line options.")
+ "This package provides a parser for command line options. As opposed to a
+declarative parser, @code{rust-clap-lex} processes arguments as a stream of tokens.")
(license (list license:expat license:asl2.0))))
(define-public rust-clearscreen-1
@@ -69097,28 +69098,6 @@ character.")
"This package provides a library to unify commandline arguments with config files and environment variables. And make it easier for users to tell your program how to behave across the three main input sources")
(license license:expat)))
-(define-public rust-clap-lex-0.2
- (package
- (name "rust-clap-lex")
- (version "0.2.4")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "clap_lex" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1ib1a9v55ybnaws11l63az0jgz5xiy24jkdgsmyl7grcm3sz4l18"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs (("rust-os-str-bytes" ,rust-os-str-bytes-6))))
- (home-page "https://github.com/clap-rs/clap/tree/master/clap_lex")
- (synopsis "Command-line parser for Rust")
- (description "This package provides a command-line parser for Rust. As
-opposed to a declarative parser, @code{rust-clap-lex} processes arguments as a
-stream of tokens.")
- (license (list license:expat license:asl2.0))))
-
(define-public svd2rust
(package
(name "svd2rust")