summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm489
1 files changed, 407 insertions, 82 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d3ae1122f9..20c2ea25f6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2092,14 +2092,14 @@ writing colored text to a terminal.")
(define-public rust-anyhow-1
(package
(name "rust-anyhow")
- (version "1.0.79")
+ (version "1.0.86")
(source
(origin
(method url-fetch)
(uri (crate-uri "anyhow" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1ji5irqiwr8yprgqj8zvnli7zd7fz9kzaiddq44jnrl2l289h3h8"))))
+ (base32 "1nk301x8qhpdaks6a9zvcp7yakjqnczjmqndbg7vk4494d3d1ldk"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -6630,8 +6630,36 @@ RFC4648 Base32 or in Crockford Base32.")
c6e7d37. However, this package works only up to 128 bytes.")
(license license:expat)))
+(define-public rust-base64-0.22
+ (package
+ (name "rust-base64")
+ (version "0.22.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "base64" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1imqzgh7bxcikp5vx3shqvw9j09g9ly0xr0jma0q66i52r7jbcvj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-development-inputs
+ (("rust-clap" ,rust-clap-3)
+ ("rust-criterion" ,rust-criterion-0.4)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rstest" ,rust-rstest-0.13)
+ ("rust-rstest-reuse" ,rust-rstest-reuse-0.6)
+ ("rust-strum" ,rust-strum-0.25))))
+ (home-page "https://github.com/marshallpierce/rust-base64")
+ (synopsis "Encodes and decodes base64 as bytes or utf8")
+ (description
+ "This package encodes and decodes base64 as bytes or utf8.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-base64-0.21
(package
+ (inherit rust-base64-0.22)
(name "rust-base64")
(version "0.21.7")
(source (origin
@@ -6641,7 +6669,6 @@ c6e7d37. However, this package works only up to 128 bytes.")
(sha256
(base32
"0rw52yvsk75kar9wgqfwgb414kvil1gn7mqkrhn9zf1537mpsacx"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-development-inputs
(("rust-clap" ,rust-clap-3)
@@ -6650,12 +6677,7 @@ c6e7d37. However, this package works only up to 128 bytes.")
("rust-rand" ,rust-rand-0.8)
("rust-rstest" ,rust-rstest-0.13)
("rust-rstest-reuse" ,rust-rstest-reuse-0.6)
- ("rust-strum" ,rust-strum-0.25))))
- (home-page "https://github.com/marshallpierce/rust-base64")
- (synopsis "Encodes and decodes base64 as bytes or utf8")
- (description
- "This package encodes and decodes base64 as bytes or utf8.")
- (license (list license:expat license:asl2.0))))
+ ("rust-strum" ,rust-strum-0.25))))))
(define-public rust-base64-0.20
(package
@@ -9160,6 +9182,36 @@ almost the same speed for encoding: about 3% slower when encoding 32 bytes.
(description "This crate provides encoding and decoding support for BSON.")
(license license:expat)))
+(define-public rust-bson-1
+ (package
+ (inherit rust-bson-2)
+ (name "rust-bson")
+ (version "1.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bson" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1cbc9mbjm4imzcv95y8r6rgl6kgv7ka5ifhhlxaqi4sv0dwaa2ny"))))
+ (arguments
+ `(#:tests? #f ; file not found for module `tests`
+ #:cargo-inputs
+ (("rust-base64" ,rust-base64-0.13)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-decimal" ,rust-decimal-2)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-linked-hash-map" ,rust-linked-hash-map-0.5)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-uuid" ,rust-uuid-0.8))
+ #:cargo-development-inputs
+ (("rust-assert-matches" ,rust-assert-matches-1)
+ ("rust-pretty-assertions" ,rust-pretty-assertions-0.6)
+ ("rust-serde-bytes" ,rust-serde-bytes-0.11))))))
+
(define-public rust-bstr-1
(package
(name "rust-bstr")
@@ -20786,6 +20838,34 @@ structs and enums.")
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-1))))))
+(define-public rust-derive-utils-0.11
+ (package
+ (name "rust-derive-utils")
+ (version "0.11.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "derive_utils" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gx7giwn8x427d5f8c92n9h0hhcqdsasvz7i8iq2rqffvhalqask"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))
+ #:cargo-development-inputs
+ (("rust-rustversion" ,rust-rustversion-1)
+ ("rust-trybuild" ,rust-trybuild-1))))
+ (home-page "https://github.com/taiki-e/derive_utils")
+ (synopsis "Macro helper for easily writing derives macros for enum")
+ (description
+ "This crate provides a procedural macro helper for easily
+writing derives macros for enums.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-derive-where-1
(package
(name "rust-derive-where")
@@ -20895,6 +20975,22 @@ intelligently transliterating them. It supports Emoji and Chinese.")
procedural macros.")
(license (list license:expat license:asl2.0))))
+(define-public rust-devise-0.3
+ (package
+ (inherit rust-devise-0.4)
+ (name "rust-devise")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "devise" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "15dmibnykic2a1ndi66shyvxmpfysnhf05lg2iv8871g0w5miish"))))
+ (arguments
+ `(#:cargo-inputs (("rust-devise-codegen" ,rust-devise-codegen-0.3)
+ ("rust-devise-core" ,rust-devise-core-0.3))))))
+
(define-public rust-devise-0.2
(package
(inherit rust-devise-0.4)
@@ -23939,14 +24035,14 @@ is configured via an environment variable.")
(package
(inherit rust-env-logger-0.11)
(name "rust-env-logger")
- (version "0.10.1")
+ (version "0.10.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "env_logger" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1kmy9xmfjaqfvd4wkxr1f7d16ld3h9b487vqs2q9r0s8f3kg7cwm"))))
+ (base32 "1005v71kay9kbz1d5907l0y7vh9qn2fqsp2yfgb8bjvin6m0bm2c"))))
(arguments
`(#:cargo-inputs
(("rust-humantime" ,rust-humantime-2)
@@ -24922,14 +25018,14 @@ by @file{sysexits.h}.")
(define-public rust-expect-test-1
(package
(name "rust-expect-test")
- (version "1.4.1")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "expect-test" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1lzqx5hqh1g4llzqby4z1d18xmrjjx63c5l0na7ycf6mmpzfmn9h"))))
+ (base32 "1q55nrkgzg345905aqbsdrwlq4sk0gjn4z5bdph1an1kc6jy02wy"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -28062,6 +28158,40 @@ the computation on the threads themselves.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-futures-enum-0.1
+ (package
+ (name "rust-futures-enum")
+ (version "0.1.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "futures-enum" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "07kvpnr21qalhw4hw44h3335wi0lgrdf02n1vglm4flhwx6x28il"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-derive-utils" ,rust-derive-utils-0.11)
+ ("rust-find-crate" ,rust-find-crate-0.6)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))
+ #:cargo-development-inputs
+ (("rust-futures" ,rust-futures-0.1)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-futures-io" ,rust-futures-io-0.3)
+ ("rust-futures-sink" ,rust-futures-sink-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3))))
+ (home-page "https://github.com/taiki-e/futures-enum")
+ (synopsis
+ "Future, Stream, Sink, AsyncRead, AsyncWrite, AsyncSeek, AsyncBufRead for enums")
+ (description
+ "This crate provides @code{#[derive(Future, Stream, Sink, AsyncRead, AsyncWrite,
+AsyncSeek, AsyncBufRead)]} for enums.")
+ (license (list license:asl2.0 license:expat))))
+
+
(define-public rust-futures-executor-0.3
(package
(name "rust-futures-executor")
@@ -30170,6 +30300,32 @@ and loading crate.")
("rust-plain" ,rust-plain-0.2)
("rust-scroll" ,rust-scroll-0.11))))))
+(define-public rust-graphql-parser-0.3
+ (package
+ (name "rust-graphql-parser")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "graphql-parser" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1wp6vnrhgi6q3b942zkc6p4mi104gbw71pnc0d5c1ps7ab7d9ayi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-combine" ,rust-combine-3)
+ ("rust-thiserror" ,rust-thiserror-1))
+ #:cargo-development-inputs
+ (("rust-pretty-assertions" ,rust-pretty-assertions-0.5))))
+ (home-page "https://github.com/graphql-rust/graphql-parser")
+ (synopsis
+ "Parser, AST and serializer for graphql query language")
+ (description
+ "This package provides a parser, AST and serializer for graphql query
+language and scheme definition language (sometimes called IDL).")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-greetd-ipc-0.9
(package
(name "rust-greetd-ipc")
@@ -34856,25 +35012,46 @@ stream runs in a TTY.")
Windows Subsystem for Linux.")
(license license:expat)))
-(define-public rust-iso8601-0.4
+(define-public rust-iso8601-0.6
(package
(name "rust-iso8601")
- (version "0.4.2")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "iso8601" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "15nfg6d4qlniw4gk7039s5y07lzgr1dp9snsw63lsxarnyz4zfg5"))))
+ (base32 "0lqif1zp19fjmrbhcdjx0ydnljax3090san5zq8r1x98x9rmsklj"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs (("rust-nom" ,rust-nom-7))))
+ `(#:cargo-inputs
+ (("rust-chrono" ,rust-chrono-0.4)
+ ("rust-nom" ,rust-nom-7)
+ ("rust-num-traits" ,rust-num-traits-0.2)
+ ("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs
+ (("rust-serde-json" ,rust-serde-json-1))))
(home-page "https://github.com/badboy/iso8601")
- (synopsis "Parsing ISO8601 dates using nom")
- (description "Parsing ISO8601 dates using nom.")
+ (synopsis "Parsing ISO8601 dates using @code{nom}")
+ (description "This crate parses ISO8601 dates using @code{nom}.")
(license license:expat)))
+(define-public rust-iso8601-0.4
+ (package
+ (inherit rust-iso8601-0.6)
+ (name "rust-iso8601")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "iso8601" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "15nfg6d4qlniw4gk7039s5y07lzgr1dp9snsw63lsxarnyz4zfg5"))))
+ (arguments
+ `(#:cargo-inputs (("rust-nom" ,rust-nom-7))))))
+
(define-public rust-iso8601-0.3
(package
(inherit rust-iso8601-0.4)
@@ -36008,26 +36185,30 @@ allocation per spawned future, whereas the futures Threadpool uses std
concurrency primitives and multiple allocations.")
(license (list license:expat license:asl2.0))))
-(define-public rust-juniper-codegen-0.14
+(define-public rust-juniper-codegen-0.15
(package
(name "rust-juniper-codegen")
- (version "0.14.2")
+ (version "0.15.9")
(source
(origin
(method url-fetch)
(uri (crate-uri "juniper_codegen" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "06ym8568k9p75kvnfc4ywqbkzaa4ib6gngx9vpbsjwg9v0sg42nl"))))
+ (base32 "1nvigsc1yrfv09wx1yv830dd60ay556haz87p80h7m8s0rqpdsdf"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? #false ;FIXME: fail due to unresolved import
+ ;; XXX: Tests fail with "error[E0599]: no variant or associated item
+ ;; named `__TestExhaustive` found for enum `syn::Type` in the current
+ ;; scope".
+ `(#:tests? #false
#:cargo-inputs
- (("rust-proc-macro2" ,rust-proc-macro2-1)
+ (("rust-proc-macro-error" ,rust-proc-macro-error-1)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-1))
#:cargo-development-inputs
- (("rust-juniper" ,rust-juniper-0.14))))
+ (("rust-juniper" ,rust-juniper-0.15))))
(home-page "https://github.com/graphql-rust/juniper")
(synopsis "Internal custom derive trait for Juniper GraphQL")
(description
@@ -36035,32 +36216,63 @@ concurrency primitives and multiple allocations.")
GraphQL.")
(license license:bsd-2)))
-(define-public rust-juniper-0.14
+(define-public rust-juniper-codegen-0.14
(package
- (name "rust-juniper")
+ (inherit rust-juniper-codegen-0.15)
+ (name "rust-juniper-codegen")
(version "0.14.2")
(source
(origin
(method url-fetch)
+ (uri (crate-uri "juniper_codegen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "06ym8568k9p75kvnfc4ywqbkzaa4ib6gngx9vpbsjwg9v0sg42nl"))))
+ (arguments
+ `(#:tests? #false ;FIXME: fail due to unresolved import
+ #:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))
+ #:cargo-development-inputs
+ (("rust-juniper" ,rust-juniper-0.14))))))
+
+(define-public rust-juniper-0.15
+ (package
+ (name "rust-juniper")
+ (version "0.15.12")
+ (source
+ (origin
+ (method url-fetch)
(uri (crate-uri "juniper" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0s56rb31yddhvjynl5bk8jihcdln8h5yfsx63kfxdhzvw98vlqpn"))))
+ (base32 "1dg1b5msr8k4kwmam2h0f64z7aamk4799vdh3cg55c881idclpc7"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-chrono" ,rust-chrono-0.4)
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-async-trait" ,rust-async-trait-0.1)
+ ("rust-bson" ,rust-bson-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-chrono-tz" ,rust-chrono-tz-0.5)
("rust-fnv" ,rust-fnv-1)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-futures-enum" ,rust-futures-enum-0.1)
+ ("rust-graphql-parser" ,rust-graphql-parser-0.3)
("rust-indexmap" ,rust-indexmap-1)
- ("rust-juniper-codegen" ,rust-juniper-codegen-0.14)
+ ("rust-juniper-codegen" ,rust-juniper-codegen-0.15)
("rust-serde" ,rust-serde-1)
- ("rust-serde-derive" ,rust-serde-derive-1)
("rust-serde-json" ,rust-serde-json-1)
+ ("rust-smartstring" ,rust-smartstring-1)
+ ("rust-static-assertions" ,rust-static-assertions-1)
("rust-url" ,rust-url-2)
- ("rust-uuid" ,rust-uuid-0.7))
+ ("rust-uuid" ,rust-uuid-0.8))
#:cargo-development-inputs
(("rust-bencher" ,rust-bencher-0.1)
- ("rust-serde-json" ,rust-serde-json-1))))
+ ("rust-pretty-assertions" ,rust-pretty-assertions-0.7)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tokio" ,rust-tokio-1))))
(home-page "https://github.com/graphql-rust/juniper")
(synopsis "GraphQL server library for Rust")
(description
@@ -36075,6 +36287,33 @@ frameworks, including embedded Graphiql and GraphQL Playground for easy
debugging.")
(license license:bsd-2)))
+(define-public rust-juniper-0.14
+ (package
+ (inherit rust-juniper-0.15)
+ (name "rust-juniper")
+ (version "0.14.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "juniper" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0s56rb31yddhvjynl5bk8jihcdln8h5yfsx63kfxdhzvw98vlqpn"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-chrono" ,rust-chrono-0.4)
+ ("rust-fnv" ,rust-fnv-1)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-juniper-codegen" ,rust-juniper-codegen-0.14)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-url" ,rust-url-2)
+ ("rust-uuid" ,rust-uuid-0.7))
+ #:cargo-development-inputs
+ (("rust-bencher" ,rust-bencher-0.1)
+ ("rust-serde-json" ,rust-serde-json-1))))))
+
(define-public rust-keccak-0.1
(package
(name "rust-keccak")
@@ -46845,14 +47084,14 @@ macros used in ntest.")
(define-public rust-num-0.4
(package
(name "rust-num")
- (version "0.4.1")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "num" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1bz7kvj94pyw4zi1pm7knziljzii218sw79ap8qfb81xkvb80ldh"))))
+ (base32 "0hbaawqgb3gsmx2i94ygbhc7nyqi6a30zbpja453n43xya5b0d9i"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -47105,17 +47344,36 @@ Rust.")
("rust-rand-xorshift" ,rust-rand-xorshift-0.3)
("rust-serde-test" ,rust-serde-test-1))))))
+(define-public rust-num-cmp-0.1
+ (package
+ (name "rust-num-cmp")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "num-cmp" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1alavi36shn32b3cwbmkncj1wal3y3cwzkm21bxy5yil5hp5ncv3"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/lifthrasiir/num-cmp")
+ (synopsis "Comparison between differently typed numbers")
+ (description
+ "This crate provides tools for comparison between differently typed
+numbers.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-num-complex-0.4
(package
(name "rust-num-complex")
- (version "0.4.4")
+ (version "0.4.6")
(source
(origin
(method url-fetch)
(uri (crate-uri "num-complex" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "051j73vvdj07kdlpqv056s3a50ragsx3183cbpl1shc51355g88v"))))
+ (base32 "15cla16mnw12xzf5g041nxbjjm9m85hdgadd5dl5d0b30w9qmy3k"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -47510,7 +47768,7 @@ directly.")
(define-public rust-num-integer-0.1
(package
(name "rust-num-integer")
- (version "0.1.45")
+ (version "0.1.46")
(source
(origin
(method url-fetch)
@@ -47518,7 +47776,7 @@ directly.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1ncwavvwdmsqzxnn65phv6c6nn72pnv9xhpmjd6a429mzf4k6p92"))))
+ "13w5g54a9184cqlbsq80rnxw4jj4s0d8wv75jsq5r2lms8gncsbr"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -47534,7 +47792,7 @@ directly.")
(define-public rust-num-iter-0.1
(package
(name "rust-num-iter")
- (version "0.1.43")
+ (version "0.1.45")
(source
(origin
(method url-fetch)
@@ -47542,7 +47800,7 @@ directly.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0lp22isvzmmnidbq9n5kbdh8gj0zm3yhxv1ddsn5rp65530fc0vx"))))
+ "1gzm7vc5g9qsjjl3bqk9rz1h6raxhygbrcpbfl04swlh0i506a8l"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -47669,14 +47927,14 @@ number of running threads for the current process.")
(define-public rust-num-traits-0.2
(package
(name "rust-num-traits")
- (version "0.2.17")
+ (version "0.2.19")
(source
(origin
(method url-fetch)
(uri (crate-uri "num-traits" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0z16bi5zwgfysz6765v3rd6whfbjpihx3mhsn4dg8dzj2c221qrr"))))
+ (base32 "0h984rhdkkqd4ny9cif7y2azl3xdfb7768hb9irhpsch4q3gq787"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -52755,17 +53013,20 @@ function data structures.")
(define-public rust-pin-project-1
(package
(name "rust-pin-project")
- (version "1.0.12")
+ (version "1.1.5")
(source
(origin
(method url-fetch)
(uri (crate-uri "pin-project" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1k3f9jkia3idxl2pqxamszwnl89dk52fa4jqj3p7zmmwnq4scadd"))))
+ (base32 "1cxl146x0q7lawp0m1826wsgj8mmmfs6ja8q7m6f7ff5j6vl7gxn"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
+ ;; XXX: Tests fail with "error[E0433]: failed to resolve: use of
+ ;; undeclared crate or module `macrotest`".
+ `(#:tests? #false
+ #:cargo-inputs
(("rust-pin-project-internal" ,rust-pin-project-internal-1))
#:cargo-development-inputs
(("rust-macrotest" ,rust-macrotest-1)
@@ -52831,21 +53092,21 @@ function data structures.")
(define-public rust-pin-project-internal-1
(package
(name "rust-pin-project-internal")
- (version "1.0.12")
+ (version "1.1.5")
(source
(origin
(method url-fetch)
(uri (crate-uri "pin-project-internal" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0maa6icn7rdfy4xvgfaq7m7bwpw9f19wg76f1ncsiixd0lgdp6q6"))))
+ (base32 "0r9r4ivwiyqf45sv6b30l1dx282lxaax2f6gl84jwa3q590s8f1g"))))
(build-system cargo-build-system)
(arguments
`(#:tests? #false
#:cargo-inputs
(("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1))))
+ ("rust-syn" ,rust-syn-2))))
(home-page "https://github.com/taiki-e/pin-project")
(synopsis "Implementation detail of the @code{pin-project} crate")
(description
@@ -55246,6 +55507,26 @@ replacements, adding colorful diffs.")
("rust-ansi-term" ,rust-ansi-term-0.11)
("rust-difference" ,rust-difference-2))))))
+(define-public rust-pretty-assertions-0.5
+ (package
+ (inherit rust-pretty-assertions-0.7)
+ (name "rust-pretty-assertions")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pretty_assertions" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ins6swkpxmrh8q5h96h8nv0497d3dclsiyx2lyvqi6py0q980is"))))
+ (arguments
+ `(#:tests? #f ;XXX: Tests fail
+ #:cargo-inputs
+ (("rust-ansi-term" ,rust-ansi-term-0.11)
+ ("rust-difference" ,rust-difference-2))))))
+
(define-public rust-pretty-assertions-0.4
(package
(inherit rust-pretty-assertions-0.6)
@@ -61235,14 +61516,14 @@ memory to speed up reallocation.")
(define-public rust-regex-1
(package
(name "rust-regex")
- (version "1.10.2")
+ (version "1.10.4")
(source
(origin
(method url-fetch)
(uri (crate-uri "regex" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0hxkd814n4irind8im5c9am221ri6bprx49nc7yxv02ykhd9a2rq"))))
+ (base32 "0k5sb0h2mkwf51ab0gvv3x38jp1q7wgxf63abfbhi0wwvvgxn5y1"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -61323,14 +61604,14 @@ uses finite automata and guarantees linear time matching on all inputs.")
(define-public rust-regex-automata-0.4
(package
(name "rust-regex-automata")
- (version "0.4.3")
+ (version "0.4.6")
(source
(origin
(method url-fetch)
(uri (crate-uri "regex-automata" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0gs8q9yhd3kcg4pr00ag4viqxnh5l7jpyb9fsfr8hzh451w4r02z"))))
+ (base32 "1spaq7y4im7s56d1gxa2hi4hzf6dwswb1bv8xyavzya7k25kpf46"))))
(build-system cargo-build-system)
(arguments
`(#:tests? #f ; Not all files included.
@@ -66530,14 +66811,14 @@ single-cell matrices.")
(define-public rust-schemars-0.8
(package
(name "rust-schemars")
- (version "0.8.16")
+ (version "0.8.20")
(source
(origin
(method url-fetch)
(uri (crate-uri "schemars" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0aadpjkaq7yl11b02pg4mwanylck328zg0q7w56dv6j89568z8j5"))))
+ (base32 "0aby31lm1jwlj5hlw5lqq7xyzhc6vrmghdjq995f5asbl7p8q8dh"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -66601,20 +66882,20 @@ Rust code.")
(define-public rust-schemars-derive-0.8
(package
(name "rust-schemars-derive")
- (version "0.8.16")
+ (version "0.8.20")
(source
(origin
(method url-fetch)
(uri (crate-uri "schemars_derive" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0rq9sdcf5hyvsyj9v9nfy2jgjbjzaldjq4i6y2fcz72xlrpzsry7"))))
+ (base32 "1lzlj36qcjjpynadbi4x152i5pd2wbv42p8n3bin5ycgrv6a3m9y"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)
- ("rust-serde-derive-internals" ,rust-serde-derive-internals-0.26)
+ ("rust-serde-derive-internals" ,rust-serde-derive-internals-0.29)
("rust-syn" ,rust-syn-1))
#:cargo-development-inputs
(("rust-pretty-assertions" ,rust-pretty-assertions-1))))
@@ -68212,29 +68493,46 @@ TOML/JSON/MessagePack strings and serializable values.")
("rust-serde-codegen-internals" ,rust-serde-codegen-internals-0.14)
("rust-syn" ,rust-syn-0.11))))))
-(define-public rust-serde-derive-internals-0.26
+(define-public rust-serde-derive-internals-0.29
(package
(name "rust-serde-derive-internals")
- (version "0.26.0")
+ (version "0.29.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "serde_derive_internals" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0g2zdr6s8i0r29yy7pdl6ahimq8w6ck70hvrciiry2ljwwlq5gw5"))))
+ (base32 "04g7macx819vbnxhi52cx0nhxi56xlhrybgwybyy7fb9m4h6mlhq"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? #f ; no variant or associated item named `__TestExhaustive`
- #:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1))))
+ ("rust-syn" ,rust-syn-2))))
(home-page "https://serde.rs")
(synopsis "AST representation used by Serde derive macros")
(description "This package provides AST representation used by Serde
derive macros.")
(license (list license:expat license:asl2.0))))
+(define-public rust-serde-derive-internals-0.26
+ (package
+ (inherit rust-serde-derive-internals-0.29)
+ (name "rust-serde-derive-internals")
+ (version "0.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "serde_derive_internals" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0g2zdr6s8i0r29yy7pdl6ahimq8w6ck70hvrciiry2ljwwlq5gw5"))))
+ (arguments
+ `(#:tests? #f ; no variant or associated item named `__TestExhaustive`
+ #:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))))
+
(define-public rust-serde-derive-internals-0.25
(package
(inherit rust-serde-derive-internals-0.26)
@@ -68772,14 +69070,14 @@ for later processing.")
(define-public rust-serde-with-3
(package
(name "rust-serde-with")
- (version "3.4.0")
+ (version "3.8.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "serde_with" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "08sw83b6hfwzylr0waf4mc29h6fxnb02g7vkwbkjjyhvrin27kb4"))
+ (base32 "082a7j42h79rs2jzafw67lay0497hnip56fdxfjxaj81mg987m0a"))
(modules '((guix build utils)))
(snippet
'(begin (substitute* "Cargo.toml"
@@ -68792,7 +69090,7 @@ for later processing.")
;; Test fails in release tarball.
"--skip=test_serde_with_macros_dependency")
#:cargo-inputs
- (("rust-base64" ,rust-base64-0.21)
+ (("rust-base64" ,rust-base64-0.22)
("rust-chrono" ,rust-chrono-0.4)
("rust-doc-comment" ,rust-doc-comment-0.3)
("rust-document-features" ,rust-document-features-0.2)
@@ -68800,7 +69098,9 @@ for later processing.")
("rust-hex" ,rust-hex-0.4)
("rust-indexmap" ,rust-indexmap-1)
("rust-indexmap" ,rust-indexmap-2)
+ ("rust-schemars" ,rust-schemars-0.8)
("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
("rust-serde-json" ,rust-serde-json-1)
("rust-serde-with-macros" ,rust-serde-with-macros-3)
("rust-time" ,rust-time-0.3))
@@ -68868,14 +69168,14 @@ Rust's serde.")
(define-public rust-serde-with-macros-3
(package
(name "rust-serde-with-macros")
- (version "3.4.0")
+ (version "3.8.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "serde_with_macros" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1277nm0ry2bs52zd5kkddgkzk5s2mhi80x74dnqj68ssyyslwqwk"))))
+ (base32 "1qmwh1bw83p8h24ijmivfaz0nifhkdvwbcdvr25kwi215xq9nmk5"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-test-flags
@@ -86663,14 +86963,14 @@ for @code{Valuable} types.")
(define-public rust-value-bag-1
(package
(name "rust-value-bag")
- (version "1.8.0")
+ (version "1.9.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "value-bag" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "07acyp7drvd5hqgy6vcrkw8sw6w9gzynkxyhrm0s9z6nbfi2dv4g"))))
+ (base32 "00aij8p1n7vcggkb9nxpwx9g5nqzclrf7prd1wpi9c3sscvw312s"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -86687,14 +86987,14 @@ for @code{Valuable} types.")
(define-public rust-value-bag-serde1-1
(package
(name "rust-value-bag-serde1")
- (version "1.8.0")
+ (version "1.9.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "value-bag-serde1" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "14fq98dm5ddlc0pzg35nk1bw3f3z8y6fhjcsy41n4s06v69vdmga"))))
+ (base32 "12rjnrh2g3ijvjgfh78y7x1ilk3mw2svri93nymsjxxhbh6gbb6c"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -86712,14 +87012,14 @@ for @code{Valuable} types.")
(define-public rust-value-bag-sval2-1
(package
(name "rust-value-bag-sval2")
- (version "1.8.0")
+ (version "1.9.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "value-bag-sval2" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "10jqa3mprd763plyabxifmvg32hrc8xn0bfqsyhc6w33h550z79v"))))
+ (base32 "0nr8453w1357xc70ilbvwcg4qa6bgll44pci0fbznb82hvjbm18p"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -87987,8 +88287,39 @@ attribute that is not in the shared backend crate.")
"This package provides a low-level @code{WebAssembly} encoder.")
(license license:asl2.0)))
+(define-public rust-wasm-streams-0.4
+ (package
+ (name "rust-wasm-streams")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wasm-streams" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0ad17c59xb8fffsnbrqbyqz93hb66nzxhizpii31icb31g4w8pdn"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-js-sys" ,rust-js-sys-0.3)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
+ ("rust-wasm-bindgen-futures" ,rust-wasm-bindgen-futures-0.4)
+ ("rust-web-sys" ,rust-web-sys-0.3))
+ #:cargo-development-inputs
+ (("rust-pin-project" ,rust-pin-project-1)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3)
+ ("rust-web-sys" ,rust-web-sys-0.3))))
+ (home-page "https://github.com/MattiasBuelens/wasm-streams/")
+ (synopsis "Bridge between web streams and Rust streams using WebAssembly")
+ (description
+ "Bridging between web streams and Rust streams using WebAssembly.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-wasm-streams-0.3
(package
+ (inherit rust-wasm-streams-0.4)
(name "rust-wasm-streams")
(version "0.3.0")
(source
@@ -87998,7 +88329,6 @@ attribute that is not in the shared backend crate.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1iqa4kmhbsjj8k4q15i1x0x4p3xda0dhbg7zw51mydr4g129sq5l"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-futures-util" ,rust-futures-util-0.3)
("rust-js-sys" ,rust-js-sys-0.3)
@@ -88008,12 +88338,7 @@ attribute that is not in the shared backend crate.")
#:cargo-development-inputs (("rust-pin-project" ,rust-pin-project-1)
("rust-tokio" ,rust-tokio-1)
("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3)
- ("rust-web-sys" ,rust-web-sys-0.3))))
- (home-page "https://github.com/MattiasBuelens/wasm-streams/")
- (synopsis "Bridge between web streams and Rust streams using WebAssembly")
- (description
- "Bridging between web streams and Rust streams using WebAssembly.")
- (license (list license:expat license:asl2.0))))
+ ("rust-web-sys" ,rust-web-sys-0.3))))))
(define-public rust-wasm-streams-0.2
(package