summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6ff2ec1c71..df8ec29022 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35416,7 +35416,7 @@ structures.")
("rust-time" ,rust-time-0.1)
("rust-typemap" ,rust-typemap-0.3)
("rust-url" ,rust-url-1))))
- (home-page "http://nickel-org.github.io/")
+ (home-page "https://nickel-org.github.io/")
(synopsis "Web application framework for Rust")
(description
"@code{nickel.rs} is a simple and lightweight foundation for web
@@ -59639,7 +59639,7 @@ fixed set of worker threads.")
("rust-log" ,rust-log-0.4)
("rust-ordered-float" ,rust-ordered-float-1)
("rust-threadpool" ,rust-threadpool-1))))
- (home-page "http://thrift.apache.org")
+ (home-page "https://thrift.apache.org")
(synopsis "Rust bindings for the Apache Thrift RPC system")
(description
"This crate provides Rust bindings for the Apache Thrift RPC system.")
@@ -62744,7 +62744,7 @@ etc. distance calculations and string search.")
("rust-trust-dns-rustls" ,rust-trust-dns-rustls-0.20)
("rust-webpki" ,rust-webpki-0.21)
("rust-webpki-roots" ,rust-webpki-roots-0.21))))
- (home-page "http://www.trust-dns.org/index.html")
+ (home-page "https://www.trust-dns.org/index.html")
(synopsis "DNS over HTTPS extension for the Trust-DNS client")
(description
"Trust-DNS is a safe and secure DNS library. This is an extension for
@@ -62878,7 +62878,7 @@ the Trust-DNS client to use DNS over HTTPS.")
("rust-tokio" ,rust-tokio-1)
("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
("rust-trust-dns-proto" ,rust-trust-dns-proto-0.20))))
- (home-page "http://www.trust-dns.org/index.html")
+ (home-page "https://www.trust-dns.org/index.html")
(synopsis "native-tls extension for the Trust-DNS client")
(description "Trust-DNS is a safe and secure DNS library. This is an
extension for the Trust-DNS client to use native-tls for TLS.")
@@ -62976,7 +62976,7 @@ extension for the Trust-DNS client to use native-tls for TLS.")
("rust-tokio" ,rust-tokio-1)
("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
("rust-trust-dns-proto" ,rust-trust-dns-proto-0.20))))
- (home-page "http://www.trust-dns.org/index.html")
+ (home-page "https://www.trust-dns.org/index.html")
(synopsis "tokio-openssl extension for the Trust-DNS client")
(description "Trust-DNS is a safe and secure DNS library. This is an
extension for the Trust-DNS client to use tokio-openssl for TLS.")
@@ -63094,7 +63094,7 @@ extension for the Trust-DNS client to use tokio-openssl for TLS.")
("rust-tokio" ,rust-tokio-1)
("rust-url" ,rust-url-2)
("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2))))
- (home-page "http://www.trust-dns.org/index.html")
+ (home-page "https://www.trust-dns.org/index.html")
(synopsis "Safe and secure DNS library")
(description
"Trust-DNS is a safe and secure DNS library. This is the foundational
@@ -63254,7 +63254,7 @@ DNS protocol library for all Trust-DNS projects.")
("rust-trust-dns-proto" ,rust-trust-dns-proto-0.20)
("rust-trust-dns-rustls" ,rust-trust-dns-rustls-0.20)
("rust-webpki-roots" ,rust-webpki-roots-0.21))))
- (home-page "http://www.trust-dns.org/index.html")
+ (home-page "https://www.trust-dns.org/index.html")
(synopsis "Safe and secure DNS library")
(description
"Trust-DNS is a safe and secure DNS library. This Resolver library uses
@@ -63403,7 +63403,7 @@ other queries.")
("rust-tokio-rustls" ,rust-tokio-rustls-0.22)
("rust-trust-dns-proto" ,rust-trust-dns-proto-0.20)
("rust-webpki" ,rust-webpki-0.21))))
- (home-page "http://www.trust-dns.org/index.html")
+ (home-page "https://www.trust-dns.org/index.html")
(synopsis "rustls extension for the Trust-DNS client")
(description
"Trust-DNS is a safe and secure DNS library. This is an extension for
@@ -64172,7 +64172,7 @@ panic-free alternative to @code{core::fmt}.")
(("rust-criterion" ,rust-criterion-0.3)
("rust-num-bigint" ,rust-num-bigint-0.4)
("rust-rug" ,rust-rug-1))))
- (home-page "http://parity.io")
+ (home-page "https://parity.io")
(synopsis "Large, fixed-size integer arithmetic in Rust")
(description "This package is a Rust library for large, fixed-size integer
arithmetic.")
@@ -68239,7 +68239,7 @@ Read/Write streams as well as low-level in-memory encoding and decoding.")
(("rust-linked-hash-map" ,rust-linked-hash-map-0.5))
#:cargo-development-inputs
(("rust-quickcheck" ,rust-quickcheck-0.9))))
- (home-page "http://chyh1990.github.io/yaml-rust/")
+ (home-page "https://chyh1990.github.io/yaml-rust/")
(synopsis "YAML 1.2 parser for Rust")
(description "This package is a YAML 1.2 parser for Rust.")
(license (list license:expat license:asl2.0))))