summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 028c140185..a10dd62e8b 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -845,8 +845,13 @@ BLAKE.")
"/bin/" ,target "-gcc"))
'())))
#:make-flags
- ;; The binaries in /bin need some help finding librhash.so.0.
- (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+ (list ;; This package uses a configure script that is not from GNU
+ ;; autotools; it doesn't handle the environment variable
+ ;; CFLAGS (or for that matter the configure option).
+ ;; Therefore, directly pass it to make.
+ "CFLAGS=-D_FILE_OFFSET_BITS=64"
+ ;; The binaries in /bin need some help finding librhash.so.0.
+ (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
#:test-target "test" ; ‘make check’ just checks the sources
#:phases
(modify-phases %standard-phases