summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 09b804f39a..51c7fd1052 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -135,17 +135,20 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
;; cups-filters package.
#:tests? #f
#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-makedefs
- (lambda _
- (substitute* "Makedefs.in"
- (("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
- (("/bin/sh") (which "sh")))))
- (add-before 'build 'patch-tests
- (lambda _
- (substitute* "test/ippserver.c"
- (("# else /\\* HAVE_AVAHI \\*/")
- "#elif defined(HAVE_AVAHI)")))))))
+ (alist-cons-before
+ 'configure
+ 'patch-makedefs
+ (lambda _
+ (substitute* "Makedefs.in"
+ (("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
+ (("/bin/sh") (which "sh"))))
+ (alist-cons-before
+ 'build
+ 'patch-tests
+ (lambda _
+ (substitute* "test/ippserver.c"
+ (("# else /\\* HAVE_AVAHI \\*/") "#elif defined(HAVE_AVAHI)")))
+ %standard-phases))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs